# CVE-2023-38504: Sails DoS vulnerability for apps with sockets enabled

> An attacker can crash the Node.js process by sending a malicious virtual request in Sails apps with sockets enabled.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Jul 2023
- **Updated:** 3 Oct 2024
- **Also known as:** GHSA-gpw9-fwm8-7rx7

## What is CVE-2023-38504?

CVE-2023-38504 is a high-severity denial of service vulnerability in balderdashy sails, published on 27 Jul 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Sails is a realtime MVC Framework for Node.js. In Sails apps prior to version 1.5.7,, an attacker can send a virtual request that will cause the node process to crash. This behavior was fixed in Sails v1.5.7. As a workaround, disable the sockets hook and remove the `sails.io.js` client.

Weakness: CWE-248 (Uncaught Exception)

## Which versions are affected by CVE-2023-38504?

2 open source packages ship an affected version, including sails. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sails` | npm | All versions | 1.5.7 |
| `sails` | npm | All versions | 1.5.7 |

Products: Sailsjs Sails.

## How do I fix CVE-2023-38504?

Upgrade sails to 1.5.7 or later.

## Is CVE-2023-38504 being exploited?

There is no known exploitation of CVE-2023-38504 in the wild and no public exploit code.

## Other vulnerabilities in balderdashy sails

- [CVE-2021-44908](https://insights.sbomify.com/CVE-2021-44908/): Prototype Pollution in Sails.js (critical 9.8)
- [CVE-2018-21036](https://insights.sbomify.com/CVE-2018-21036/): Improper Input Validation in sails-hook-sockets (high 7.5)
- [CVE-2016-10549](https://insights.sbomify.com/CVE-2016-10549/): Sails before 0.12.7 vulnerable to Broken CORS (medium 4.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-38504 and fix it if it is affected.

What it is: CVE-2023-38504 is a high-severity denial of service vulnerability in balderdashy sails, published on 27 Jul 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-38504 in the wild and no public exploit code.

Affected packages and fixed versions:
- sails (npm): affected all versions; fixed in 1.5.7
- sails (npm): affected all versions; fixed in 1.5.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-38504/ (Markdown: https://insights.sbomify.com/CVE-2023-38504/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-38504
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-38504
- OSV: https://osv.dev/vulnerability/CVE-2023-38504

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-38504/
Summaries are generated and may contain mistakes; the official description above is the record.
