{"answers":{"affected":"4 open source packages ship an affected version, including @strapi/admin and @strapi/plugin-users-permissions. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-38507 exists.","fix":"Upgrade @strapi/admin to 4.12.1 or later.","what":"CVE-2023-38507 is a high-severity vulnerability in strapi, published on 15 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-38507 and fix it if it is affected.\n\nWhat it is: CVE-2023-38507 is a high-severity vulnerability in strapi, published on 15 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-38507 exists.\n\nAffected packages and fixed versions:\n- @strapi/admin (npm): affected all versions; fixed in 4.12.1\n- @strapi/admin (npm): affected all versions; fixed in 4.12.1\n- @strapi/plugin-users-permissions (npm): affected all versions; fixed in 4.12.1\n- @strapi/plugin-users-permissions (npm): affected all versions; fixed in 4.12.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-38507/ (Markdown: https://insights.sbomify.com/CVE-2023-38507/index.md)","id":"CVE-2023-38507","markdown":"https://insights.sbomify.com/CVE-2023-38507/index.md","name":"CVE-2023-38507","record":{"aliases":["GHSA-24q2-59hm-rh9r"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Strapi CMS","requires_auth":"none","summary":"Attackers can bypass login rate limits in Strapi to perform brute-force attacks, potentially leading to unauthorized account access.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"strapi","vendor":"strapi"}],"cvss":{"score":7.3,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"}],"description":"Strapi is the an open-source headless content management system. Prior to version 4.12.1, there is a rate limit on the login function of Strapi's admin screen, but it is possible to circumvent it. Therefore, the possibility of unauthorized login by login brute force attack increases. Version 4.12.1 has a fix for this issue.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Strapi Improper Rate Limiting vulnerability","id":"CVE-2023-38507","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"security_feature_bypass","year":"2023"},"n_packages":4,"n_references":3,"next":{"headline":"Tuleap allows preview of a linked artifact with a type does not respect permissions","id":"CVE-2023-38508"},"packages":[{"ecosystem":"npm","fixed":["4.12.1"],"introduced":["0"],"last_affected":[],"package":"@strapi/admin","purl":null,"source":"GHSA-24q2-59hm-rh9r"},{"ecosystem":"npm","fixed":["4.12.1"],"introduced":["0"],"last_affected":[],"package":"@strapi/admin","purl":"pkg:npm/%40strapi/admin","source":"GHSA-24q2-59hm-rh9r"},{"ecosystem":"npm","fixed":["4.12.1"],"introduced":["0"],"last_affected":[],"package":"@strapi/plugin-users-permissions","purl":null,"source":"GHSA-24q2-59hm-rh9r"},{"ecosystem":"npm","fixed":["4.12.1"],"introduced":["0"],"last_affected":[],"package":"@strapi/plugin-users-permissions","purl":"pkg:npm/%40strapi/plugin-users-permissions","source":"GHSA-24q2-59hm-rh9r"}],"prev":{"headline":"Cross-site Scripting (XSS) when pasting HTML into the rich text editor in Joplin","id":"CVE-2023-38506"},"products":["strapi"],"published":"2023-09-15","related":[{"cvss_score":7.2,"headline":"Strapi Cleartext Storage of Sensitive Information","id":"CVE-2023-22894","kev_date_added":"2026-10-08","published":"2023-04-19"},{"cvss_score":10,"headline":"Strapi plugins vulnerable to Server-Side Template Injection and Remote Code Execution in the Users-Permissions Plugin","id":"CVE-2023-22621","kev_date_added":null,"published":"2023-04-19"},{"cvss_score":9.8,"headline":"Unrestricted Upload of File with Dangerous Type in Strapi","id":"CVE-2022-27263","kev_date_added":null,"published":"2022-04-12"},{"cvss_score":9.8,"headline":"Authorization bypass in Strapi","id":"CVE-2020-27664","kev_date_added":null,"published":"2020-10-22"},{"cvss_score":9.8,"headline":"Strapi allows unauthenticated attacker to reset admin password without valid reset token","id":"CVE-2019-18818","kev_date_added":null,"published":"2019-11-07"},{"cvss_score":9.3,"headline":"Strapi Vulnerable to SQL Injection in Content Type Builder","id":"CVE-2026-22599","kev_date_added":null,"published":"2026-05-14"},{"cvss_score":9.2,"headline":"Strapi may leak sensitive data via relational filtering due to lack of query sanitization","id":"CVE-2026-27886","kev_date_added":null,"published":"2026-05-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-09-25","vendors":["strapi"]},"summary":"Attackers can bypass login rate limits in Strapi to perform brute-force attacks, potentially leading to unauthorized account access.","url":"https://insights.sbomify.com/CVE-2023-38507/"}