# CVE-2023-38507: Strapi Improper Rate Limiting vulnerability

> Attackers can bypass login rate limits in Strapi to perform brute-force attacks, potentially leading to unauthorized account access.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Sep 2023
- **Updated:** 25 Sep 2024
- **Also known as:** GHSA-24q2-59hm-rh9r

## What is CVE-2023-38507?

CVE-2023-38507 is a high-severity vulnerability in strapi, published on 15 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Strapi is the an open-source headless content management system. Prior to version 4.12.1, there is a rate limit on the login function of Strapi's admin screen, but it is possible to circumvent it. Therefore, the possibility of unauthorized login by login brute force attack increases. Version 4.12.1 has a fix for this issue.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2023-38507?

4 open source packages ship an affected version, including @strapi/admin and @strapi/plugin-users-permissions. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@strapi/admin` | npm | All versions | 4.12.1 |
| `@strapi/admin` | npm | All versions | 4.12.1 |
| `@strapi/plugin-users-permissions` | npm | All versions | 4.12.1 |
| `@strapi/plugin-users-permissions` | npm | All versions | 4.12.1 |

Products: Strapi Strapi.

## How do I fix CVE-2023-38507?

Upgrade @strapi/admin to 4.12.1 or later.

## Is CVE-2023-38507 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-38507 exists.

## Other vulnerabilities in strapi

- [CVE-2023-22894](https://insights.sbomify.com/CVE-2023-22894/): Strapi Cleartext Storage of Sensitive Information (high 7.2, exploited in the wild)
- [CVE-2023-22621](https://insights.sbomify.com/CVE-2023-22621/): Strapi plugins vulnerable to Server-Side Template Injection and Remote Code Execution in the Users-Permissions Plugin (critical 10.0)
- [CVE-2022-27263](https://insights.sbomify.com/CVE-2022-27263/): Unrestricted Upload of File with Dangerous Type in Strapi (critical 9.8)
- [CVE-2020-27664](https://insights.sbomify.com/CVE-2020-27664/): Authorization bypass in Strapi (critical 9.8)
- [CVE-2019-18818](https://insights.sbomify.com/CVE-2019-18818/): Strapi allows unauthenticated attacker to reset admin password without valid reset token (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-38507 and fix it if it is affected.

What it is: CVE-2023-38507 is a high-severity vulnerability in strapi, published on 15 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-38507 exists.

Affected packages and fixed versions:
- @strapi/admin (npm): affected all versions; fixed in 4.12.1
- @strapi/admin (npm): affected all versions; fixed in 4.12.1
- @strapi/plugin-users-permissions (npm): affected all versions; fixed in 4.12.1
- @strapi/plugin-users-permissions (npm): affected all versions; fixed in 4.12.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-38507/ (Markdown: https://insights.sbomify.com/CVE-2023-38507/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-38507
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-38507
- OSV: https://osv.dev/vulnerability/CVE-2023-38507

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-38507/
Summaries are generated and may contain mistakes; the official description above is the record.
