# CVE-2023-38509: XWiki Platform's obfuscated email addresses should not be sorted

> Attackers can retrieve obfuscated email addresses from XWiki Platform due to improper sorting logic, exposing user contact information.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Jul 2023
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-g9w4-prf3-m25g

## What is CVE-2023-38509?

CVE-2023-38509 is a medium-severity vulnerability in Xwiki Xwiki, published on 27 Jul 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

XWiki Platform is a generic wiki platform. In org.xwiki.platform:xwiki-platform-livetable-ui starting with version 3.5-milestone-1 and prior to versions 14.10.9 and 15.3-rc-1, the mail obfuscation configuration was not fully taken into account and is was still possible by obfuscated emails. This has been patched in XWiki 14.10.9 and XWiki 15.3-rc-1. A workaround is to modify the page `XWiki.LiveTableResultsMacros` following the patch.

Weakness: CWE-402 (Transmission of Private Resources into a New Sphere)

## Which versions are affected by CVE-2023-38509?

4 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-livetable-ui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-livetable-ui` | Maven | From 15.0 | 15.3-rc-1 |
| `org.xwiki.platform:xwiki-platform-livetable-ui` | Maven | From 15.0 | 15.3-rc-1 |
| `org.xwiki.platform:xwiki-platform-livetable-ui` | Maven | From 3.5-milestone-1 | 14.10.9 |
| `org.xwiki.platform:xwiki-platform-livetable-ui` | Maven | From 3.5-milestone-1 | 14.10.9 |

Products: Xwiki Xwiki.

## How do I fix CVE-2023-38509?

Upgrade org.xwiki.platform:xwiki-platform-livetable-ui to a fixed version for your release line: 15.3-rc-1 or 14.10.9.

## Is CVE-2023-38509 being exploited?

There is no known exploitation of CVE-2023-38509 in the wild and no public exploit code.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-38509 and fix it if it is affected.

What it is: CVE-2023-38509 is a medium-severity vulnerability in Xwiki Xwiki, published on 27 Jul 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-38509 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-livetable-ui (Maven): affected from 15.0; fixed in 15.3-rc-1
- org.xwiki.platform:xwiki-platform-livetable-ui (Maven): affected from 15.0; fixed in 15.3-rc-1
- org.xwiki.platform:xwiki-platform-livetable-ui (Maven): affected from 3.5-milestone-1; fixed in 14.10.9
- org.xwiki.platform:xwiki-platform-livetable-ui (Maven): affected from 3.5-milestone-1; fixed in 14.10.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-38509/ (Markdown: https://insights.sbomify.com/CVE-2023-38509/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-38509
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-38509
- OSV: https://osv.dev/vulnerability/CVE-2023-38509

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-38509/
Summaries are generated and may contain mistakes; the official description above is the record.
