CVE-2023-38510 Tolgee Lacks Permission Check for API Key for some endpoints

High 8.1 Published Updated

Attackers with exposed API keys can bypass permission checks on certain endpoints, potentially accessing unauthorized data in Tolgee localization projects.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2023-38510?

CVE-2023-38510 is a high-severity missing authorization vulnerability in tolgee-platform, published on 27 Jul 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Tolgee is an open-source localization platform. Starting in version 3.14.0 and prior to version 3.23.1, when a request is made using an API key, the backend fails to verify the permission scopes associated with the key, effectively bypassing permission checks entirely for some endpoints. It's important to note that this vulnerability only affects projects that have inadvertently exposed their API keys on the internet. Projects that have kept their API keys secure are not impacted. This issue is fixed in version 3.23.1.

Weakness: CWE-862

Which versions are affected by CVE-2023-38510?

It affects 1 product.

Products include Tolgee Tolgee.

How do I fix CVE-2023-38510?

No fix has been published for CVE-2023-38510 yet. Limit exposure of the affected software until one is available.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2023-38510 being exploited?

There is no known exploitation of CVE-2023-38510 in the wild and no public exploit code.

Sources

Also known as GHSA-4f9j-4vh4-p85v.

Is CVE-2023-38510 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free