CVE-2023-38519 WordPress MainWP Plugin <= 4.4.3.3 is vulnerable to SQL Injection

High 7.6 Published Updated

An attacker can execute arbitrary SQL commands via the MainWP Dashboard plugin, potentially reading or modifying database contents.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-38519?

CVE-2023-38519 is a high-severity SQL injection vulnerability in MainWP Dashboard – WordPress Manager for Multiple Websites Maintenance, published on 20 Dec 2023. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in MainWP MainWP Dashboard – WordPress Manager for Multiple Websites Maintenance.This issue affects MainWP Dashboard – WordPress Manager for Multiple Websites Maintenance: from n/a through 4.4.3.3.

Weakness: CWE-89

Which versions are affected by CVE-2023-38519?

2 open source packages ship an affected version, including mainwp/mainwp. It affects 1 product.

PackageAffectedFixed in
mainwp/mainwp PackagistAll versions4.4.3.4
mainwp/mainwp PackagistAll versions4.4.3.4

Products include Mainwp Mainwp Dashboard.

How do I fix CVE-2023-38519?

Upgrade mainwp/mainwp to 4.4.3.4 or later.

Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.

Is CVE-2023-38519 being exploited?

There is no known exploitation of CVE-2023-38519 in the wild and no public exploit code.

Sources

Also known as GHSA-87fg-9x5w-j3rm.

Is CVE-2023-38519 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free