{"answers":{"affected":"2 open source packages ship an affected version, including mainwp/mainwp. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-38519 in the wild and no public exploit code.","fix":"Upgrade mainwp/mainwp to 4.4.3.4 or later.","what":"CVE-2023-38519 is a high-severity SQL injection vulnerability in MainWP Dashboard – WordPress Manager for Multiple Websites Maintenance, published on 20 Dec 2023. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-38519 and fix it if it is affected.\n\nWhat it is: CVE-2023-38519 is a high-severity SQL injection vulnerability in MainWP Dashboard – WordPress Manager for Multiple Websites Maintenance, published on 20 Dec 2023. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-38519 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- mainwp/mainwp (Packagist): affected all versions; fixed in 4.4.3.4\n- mainwp/mainwp (Packagist): affected all versions; fixed in 4.4.3.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-38519/ (Markdown: https://insights.sbomify.com/CVE-2023-38519/index.md)","id":"CVE-2023-38519","markdown":"https://insights.sbomify.com/CVE-2023-38519/index.md","name":"CVE-2023-38519","record":{"aliases":["GHSA-87fg-9x5w-j3rm"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"high_privilege","summary":"An attacker can execute arbitrary SQL commands via the MainWP Dashboard plugin, potentially reading or modifying database contents.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Patchstack","cpe":[{"product":"mainwp_dashboard","vendor":"mainwp"}],"cvss":{"score":7.6,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"}],"description":"Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in MainWP MainWP Dashboard – WordPress Manager for Multiple Websites Maintenance.This issue affects MainWP Dashboard – WordPress Manager for Multiple Websites Maintenance: from n/a through 4.4.3.3.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"WordPress MainWP Plugin \u003c= 4.4.3.3 is vulnerable to SQL Injection","id":"CVE-2023-38519","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"sql_injection","year":"2023"},"n_packages":2,"n_references":1,"next":{"headline":"WordPress Pinpoint Booking System plugin \u003c= 2.9.9.3.4 - Parameter Tampering","id":"CVE-2023-38520"},"packages":[{"ecosystem":"Packagist","fixed":["4.4.3.4"],"introduced":["0"],"last_affected":[],"package":"mainwp/mainwp","purl":null,"source":"GHSA-87fg-9x5w-j3rm"},{"ecosystem":"Packagist","fixed":["4.4.3.4"],"introduced":["0"],"last_affected":[],"package":"mainwp/mainwp","purl":"pkg:composer/mainwp/mainwp","source":"GHSA-87fg-9x5w-j3rm"}],"prev":{"headline":"WordPress Borderless Plugin \u003c= 1.4.8 is vulnerable to Cross Site Scripting (XSS)","id":"CVE-2023-38518"},"products":["MainWP Dashboard – WordPress Manager for Multiple Websites Maintenance"],"published":"2023-12-20","related":[{"cvss_score":7.2,"headline":"Cross-site scripting in MainWP Dashboard: Self-hosted WordPress Management for Agencies","id":"CVE-2016-15041","kev_date_added":null,"published":"2024-10-16"},{"cvss_score":4.3,"headline":"MainWP Dashboard \u003c= 4.6.0.1 - Cross-Site Request Forgery via posting_bulk","id":"CVE-2024-1642","kev_date_added":null,"published":"2024-03-13"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2026-04-28","vendors":["MainWP"]},"summary":"An attacker can execute arbitrary SQL commands via the MainWP Dashboard plugin, potentially reading or modifying database contents.","url":"https://insights.sbomify.com/CVE-2023-38519/"}