# CVE-2023-38671: Heap buffer overflow in paddle.trace

> A heap buffer overflow in PaddlePaddle's trace function allows attackers to cause denial of service or disclose sensitive information.

- **Severity:** High 8.3 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Jul 2023
- **Updated:** 23 Oct 2024
- **Also known as:** GHSA-hh7p-hvm3-rg88, PYSEC-2023-124

## What is CVE-2023-38671?

CVE-2023-38671 is a high-severity memory corruption vulnerability in PaddlePaddle, published on 26 Jul 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Heap buffer overflow in paddle.trace in PaddlePaddle before 2.5.0. This flaw can lead to a denial of service, information disclosure, or more damage is possible.

Weakness: CWE-787 (Out-of-bounds Write), CWE-120 (Buffer Copy without Checking Size of Input)

## Which versions are affected by CVE-2023-38671?

3 open source packages ship an affected version, including paddlepaddle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `paddlepaddle` | PyPI | All versions | 2.5.0 |
| `paddlepaddle` | PyPI | All versions | 2.5.0 |
| `paddlepaddle` | PyPI | All versions | 2.5.0 |

Products: Paddlepaddle Paddlepaddle.

## How do I fix CVE-2023-38671?

Upgrade paddlepaddle to 2.5.0 or later.

## Is CVE-2023-38671 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-38671 exists.

## Other vulnerabilities in PaddlePaddle

- [CVE-2022-46742](https://insights.sbomify.com/CVE-2022-46742/): PaddlePaddle vulnerable to Code Injection (critical 10.0)
- [CVE-2022-45908](https://insights.sbomify.com/CVE-2022-45908/): PaddlePaddle vulnerable to code injection via winstr (critical 9.8)
- [CVE-2023-52310](https://insights.sbomify.com/CVE-2023-52310/): Command injection in get_online_pass_interval (critical 9.6)
- [CVE-2023-52311](https://insights.sbomify.com/CVE-2023-52311/): Command injection in _wget_download (critical 9.6)
- [CVE-2023-52314](https://insights.sbomify.com/CVE-2023-52314/): Command injection in convert_shape_compare (critical 9.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-38671 and fix it if it is affected.

What it is: CVE-2023-38671 is a high-severity memory corruption vulnerability in PaddlePaddle, published on 26 Jul 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-38671 exists.

Affected packages and fixed versions:
- paddlepaddle (PyPI): affected all versions; fixed in 2.5.0
- paddlepaddle (PyPI): affected all versions; fixed in 2.5.0
- paddlepaddle (PyPI): affected all versions; fixed in 2.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-38671/ (Markdown: https://insights.sbomify.com/CVE-2023-38671/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-38671
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-38671
- OSV: https://osv.dev/vulnerability/CVE-2023-38671

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-38671/
Summaries are generated and may contain mistakes; the official description above is the record.
