{"answers":{"affected":"2 open source packages ship an affected version, including svelecte. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-38687 exists.","fix":"Upgrade svelecte to 3.16.3 or later.","what":"CVE-2023-38687 is a medium-severity cross-site scripting vulnerability in mskocik svelecte, published on 14 Aug 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-38687 and fix it if it is affected.\n\nWhat it is: CVE-2023-38687 is a medium-severity cross-site scripting vulnerability in mskocik svelecte, published on 14 Aug 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-38687 exists.\n\nAffected packages and fixed versions:\n- svelecte (npm): affected all versions; fixed in 3.16.3\n- svelecte (npm): affected all versions; fixed in 3.16.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-38687/ (Markdown: https://insights.sbomify.com/CVE-2023-38687/index.md)","id":"CVE-2023-38687","markdown":"https://insights.sbomify.com/CVE-2023-38687/index.md","name":"CVE-2023-38687","record":{"aliases":["GHSA-7h45-grc5-89wq"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Svelte autocomplete component","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary JavaScript via unescaped HTML in Svelecte item names, affecting applications using this Svelte component.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"svelecte","vendor":"mskocik"}],"cvss":{"score":5.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Svelecte is a flexible autocomplete/select component written in Svelte. Svelecte item names are rendered as raw HTML with no escaping. This allows the injection of arbitrary HTML into the Svelecte dropdown. This can be exploited to execute arbitrary JavaScript whenever a Svelecte dropdown is opened. Item names given to Svelecte appear to be directly rendered as HTML by the default item renderer. This means that any HTML tags in the name are rendered as HTML elements not as text. Note that the custom item renderer shown in https://mskocik.github.io/svelecte/#item-rendering is also vulnerable to the same exploit. Any site that uses Svelecte with dynamically created items either from an external source or from user-created content could be vulnerable to an XSS attack (execution of untrusted JavaScript), clickjacking or any other attack that can be performed with arbitrary HTML injection. The actual impact of this vulnerability for a specific application depends on how trustworthy the sources that provide Svelecte items are and the steps that the application has taken to mitigate XSS attacks. XSS attacks using this vulnerability are mostly mitigated by a Content Security Policy that blocks inline JavaScript. This issue has been addressed in version 3.16.3. Users are advised to upgrade. There are no known workarounds for this vulnerability.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Execution of arbitrary JavaScript from Svelecte item names","id":"CVE-2023-38687","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2023"},"n_packages":2,"n_references":1,"next":{"headline":"twitch-tui's connection is not encrypted","id":"CVE-2023-38688"},"packages":[{"ecosystem":"npm","fixed":["3.16.3"],"introduced":["0"],"last_affected":[],"package":"svelecte","purl":null,"source":"GHSA-7h45-grc5-89wq"},{"ecosystem":"npm","fixed":["3.16.3"],"introduced":["0"],"last_affected":[],"package":"svelecte","purl":"pkg:npm/svelecte","source":"GHSA-7h45-grc5-89wq"}],"prev":{"headline":"Sydent does not verify email server certificates","id":"CVE-2023-38686"},"products":["svelecte"],"published":"2023-08-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-10-02","vendors":["mskocik"]},"summary":"Attackers can execute arbitrary JavaScript via unescaped HTML in Svelecte item names, affecting applications using this Svelte component.","url":"https://insights.sbomify.com/CVE-2023-38687/"}