# CVE-2023-38688: twitch-tui's connection is not encrypted

> Attackers can sniff unencrypted Twitch chat traffic and steal auth tokens because the client disables TLS by default.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Aug 2023
- **Updated:** 9 Oct 2024
- **Also known as:** GHSA-779w-xvpm-78jx

## What is CVE-2023-38688?

CVE-2023-38688 is a high-severity vulnerability in Xithrius twitch-tui, published on 4 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

twitch-tui provides Twitch chat in a terminal. Prior to version 2.4.1, the connection is not using TLS for communication. In the configuration of the irc connection, the software disables TLS, which makes all communication to Twitch IRC servers unencrypted. As a result, communication, including auth tokens, can be sniffed. Version 2.4.1 has a patch for this issue.

Weakness: CWE-311 (Missing Encryption of Sensitive Data)

## Which versions are affected by CVE-2023-38688?

2 open source packages ship an affected version, including twitch-tui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `twitch-tui` | crates.io | All versions | 2.4.1 |
| `twitch-tui` | crates.io | All versions | 2.4.1 |

Products: Xithrius Twitch-Tui.

## How do I fix CVE-2023-38688?

Upgrade twitch-tui to 2.4.1 or later.

## Is CVE-2023-38688 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-38688 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-38688 and fix it if it is affected.

What it is: CVE-2023-38688 is a high-severity vulnerability in Xithrius twitch-tui, published on 4 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-38688 exists.

Affected packages and fixed versions:
- twitch-tui (crates.io): affected all versions; fixed in 2.4.1
- twitch-tui (crates.io): affected all versions; fixed in 2.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-38688/ (Markdown: https://insights.sbomify.com/CVE-2023-38688/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-38688
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-38688
- OSV: https://osv.dev/vulnerability/CVE-2023-38688

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-38688/
Summaries are generated and may contain mistakes; the official description above is the record.
