{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-38689 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2023-38689 yet. Limit exposure of the affected software until one is available.","what":"CVE-2023-38689 is a high-severity unsafe deserialization vulnerability in RS485 LogisticsPipes, published on 4 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-38689 and fix it if it is affected.\n\nWhat it is: CVE-2023-38689 is a high-severity unsafe deserialization vulnerability in RS485 LogisticsPipes, published on 4 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-38689 in the wild and no public exploit code.\n\nAffected product: RS485 LogisticsPipes. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-38689/ (Markdown: https://insights.sbomify.com/CVE-2023-38689/index.md)","id":"CVE-2023-38689","markdown":"https://insights.sbomify.com/CVE-2023-38689/index.md","name":"CVE-2023-38689","record":{"aliases":["GHSA-mcp7-xf3v-25x3"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Minecraft mod","requires_auth":"none","summary":"Remote attackers can execute arbitrary code by sending crafted network packets to vulnerable Logistics Pipes Minecraft mods.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"logisticspipes","vendor":"rs485"}],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"Logistics Pipes is a modification (a.k.a. mod) for the computer game Minecraft Java Edition. The mod used Java's `ObjectInputStream#readObject` on untrusted data coming from clients or servers over the network resulting in possible remote code execution when sending specifically crafted network packets after connecting. The affected versions were released between 2013 and 2016 and the issue (back then unknown) was fixed in 2016 by a refactoring of the network IO code.  \nThe issue is present in all Logistics Pipes versions ranged from 0.7.0.91 prior to 0.10.0.71, which were downloaded from different platforms summing up to multi-million downloads. For Minecraft version 1.7.10 the issue was fixed in build 0.10.0.71. Everybody on Minecraft 1.7.10 should check their version number of Logistics Pipes in their modlist and update, if the version number is smaller than 0.10.0.71. Any newer supported Minecraft version (like 1.12.2) never had a Logistics Pipes version with vulnerable code. The best available workaround for vulnerable versions is to play in singleplayer only or update to newer Minecraft versions and modpacks.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Deserialization of Untrusted Data in network IO","id":"CVE-2023-38689","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"deserialization","year":"2023"},"n_packages":0,"n_references":3,"next":{"headline":"matrix-appservice-irc IRC command injection via admin commands containing newlines","id":"CVE-2023-38690"},"packages":[],"prev":{"headline":"twitch-tui's connection is not encrypted","id":"CVE-2023-38688"},"products":["LogisticsPipes"],"published":"2023-08-04","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-10-10","vendors":["RS485"]},"summary":"Remote attackers can execute arbitrary code by sending crafted network packets to vulnerable Logistics Pipes Minecraft mods.","url":"https://insights.sbomify.com/CVE-2023-38689/"}