# CVE-2023-38692: Command injection vulnerability in module management function in CloudExplorer Lite


- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 4 Aug 2023
- **Updated:** 10 Oct 2024
- **Also known as:** GHSA-7wrc-f42m-9v5w

## What is CVE-2023-38692?

CVE-2023-38692 is a critical vulnerability in CloudExplorer-Dev CloudExplorer-Lite, published on 4 Aug 2023. 

### Official description

CloudExplorer Lite is an open source, lightweight cloud management platform. Versions prior to 1.3.1 contain a command injection vulnerability in the installation function in module management. The vulnerability has been fixed in v1.3.1. There are no known workarounds aside from upgrading.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2023-38692?

It affects 1 product.


Products: Fit2cloud Cloudexplorer Lite.

## How do I fix CVE-2023-38692?

No fix has been published for CVE-2023-38692 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-38692 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-38692 exists.

## Other vulnerabilities in CloudExplorer-Dev CloudExplorer-Lite

- [CVE-2023-2845](https://insights.sbomify.com/CVE-2023-2845/): Improper Access Control in cloudexplorer-dev/cloudexplorer-lite (high 8.8)
- [CVE-2023-50612](https://insights.sbomify.com/CVE-2023-50612/): Privilege escalation in n/a (high 7.8)
- [CVE-2023-44397](https://insights.sbomify.com/CVE-2023-44397/): CloudExplorer Lite permission bypass vulnerability (high 7.5)
- [CVE-2023-42147](https://insights.sbomify.com/CVE-2023-42147/): Information disclosure in n/a (high 7.5)
- [CVE-2023-39519](https://insights.sbomify.com/CVE-2023-39519/): CloudExplorer Lite sensitive information leakage vulnerability (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-38692 and fix it if it is affected.

What it is: CVE-2023-38692 is a critical vulnerability in CloudExplorer-Dev CloudExplorer-Lite, published on 4 Aug 2023. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-38692 exists.

Affected product: CloudExplorer-Dev CloudExplorer-Lite. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-38692/ (Markdown: https://insights.sbomify.com/CVE-2023-38692/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-38692
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-38692
- OSV: https://osv.dev/vulnerability/CVE-2023-38692

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-38692/
Summaries are generated and may contain mistakes; the official description above is the record.
