# CVE-2023-38699: MindsDB 'Call to requests with verify=False disabling SSL certificate checks, security issue.' issue

> MindsDB disabled SSL certificate verification, allowing attackers to intercept data via man-in-the-middle attacks.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Aug 2023
- **Updated:** 3 Oct 2024
- **Also known as:** GHSA-8hx6-qv6f-xgcw, PYSEC-2023-140

## What is CVE-2023-38699?

CVE-2023-38699 is a critical vulnerability in mindsdb, published on 4 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

MindsDB's AI Virtual Database allows developers to connect any AI/ML model to any datasource. Prior to version 23.7.4.0, a call to requests with `verify=False` disables SSL certificate checks. This rule enforces always verifying SSL certificates for methods in the Requests library. In version 23.7.4.0, certificates are validated by default, which is the desired behavior.

Weakness: CWE-311 (Missing Encryption of Sensitive Data)

## Which versions are affected by CVE-2023-38699?

3 open source packages ship an affected version, including mindsdb and MindsDB. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mindsdb` | PyPI | All versions | 23.7.4.0 |
| `mindsdb` | PyPI | All versions | 23.7.4.0 |
| `MindsDB` | PyPI | All versions | 23.7.4.0 |

Products: Mindsdb Mindsdb.

## How do I fix CVE-2023-38699?

Upgrade mindsdb to 23.7.4.0 or later.

## Is CVE-2023-38699 being exploited?

There is no known exploitation of CVE-2023-38699 in the wild and no public exploit code.

## Other vulnerabilities in mindsdb

- [CVE-2024-24759](https://insights.sbomify.com/CVE-2024-24759/): MindsDB Vulnerable to Bypass of SSRF Protection with DNS Rebinding (critical 9.3)
- [CVE-2023-50731](https://insights.sbomify.com/CVE-2023-50731/): MindsDB has arbitrary file write in file.py (critical 9.1)
- [CVE-2024-45856](https://insights.sbomify.com/CVE-2024-45856/): MindsDB Cross-site Scripting vulnerability (critical 9.0)
- [CVE-2026-27483](https://insights.sbomify.com/CVE-2026-27483/): MindsDB has Path Traversal in /api/files Leading to Remote Code Execution (high 8.8)
- [CVE-2024-45846](https://insights.sbomify.com/CVE-2024-45846/): MindsDB Eval Injection vulnerability (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-38699 and fix it if it is affected.

What it is: CVE-2023-38699 is a critical vulnerability in mindsdb, published on 4 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-38699 in the wild and no public exploit code.

Affected packages and fixed versions:
- mindsdb (PyPI): affected all versions; fixed in 23.7.4.0
- mindsdb (PyPI): affected all versions; fixed in 23.7.4.0
- MindsDB (PyPI): affected all versions; fixed in 23.7.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-38699/ (Markdown: https://insights.sbomify.com/CVE-2023-38699/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-38699
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-38699
- OSV: https://osv.dev/vulnerability/CVE-2023-38699

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-38699/
Summaries are generated and may contain mistakes; the official description above is the record.
