CVE-2023-38706 Discourse vulnerable to DoS via drafts

Medium 6.5 Published Updated

A malicious user can exhaust server resources by creating unlimited drafts with long keys, causing denial of service in Discourse.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-38706?

CVE-2023-38706 is a medium-severity denial of service vulnerability in Discourse Discourse, published on 15 Sep 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Discourse is an open-source discussion platform. Prior to version 3.1.1 of the `stable` branch and version 3.2.0.beta1 of the `beta` and `tests-passed` branches, a malicious user can create an unlimited number of drafts with very long draft keys which may end up exhausting the resources on the server. The issue is patched in version 3.1.1 of the `stable` branch and version 3.2.0.beta1 of the `beta` and `tests-passed` branches. There are no known workarounds.

Weakness: CWE-770

Which versions are affected by CVE-2023-38706?

1 open source package ship an affected version, including discourse. It affects 1 product.

PackageAffectedFixed in
discourse BitnamiAll versions3.1.1

Products include Discourse Discourse.

How do I fix CVE-2023-38706?

Upgrade discourse to 3.1.1 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2023-38706 being exploited?

There is no known exploitation of CVE-2023-38706 in the wild and no public exploit code.

All Discourse Discourse vulnerabilities

Sources

Also known as BIT-discourse-2023-38706, GHSA-7wpp-4pqg-gvp8.

Is CVE-2023-38706 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free