# CVE-2023-38860: LangChain vulnerable to arbitrary code execution

> Remote attackers can execute arbitrary code via the prompt parameter in the LangChain library, requiring developers to upgrade to a patched version.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Aug 2023
- **Updated:** 9 Oct 2024
- **Also known as:** GHSA-fj32-q626-pjjc, PYSEC-2023-145

## What is CVE-2023-38860?

CVE-2023-38860 is a critical code injection vulnerability in n/a, published on 15 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue in LangChain v.0.0.231 allows a remote attacker to execute arbitrary code via the prompt parameter.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2023-38860?

3 open source packages ship an affected version, including langchain. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `langchain` | PyPI | All versions | 0.0.247 |
| `langchain` | PyPI | All versions | 0.0.247 |
| `langchain` | PyPI | All versions | 0.0.247 |

Products: Langchain Langchain.

## How do I fix CVE-2023-38860?

Upgrade langchain to 0.0.247 or later.

## Is CVE-2023-38860 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-38860 exists.

## Other vulnerabilities in n/a

- [CVE-2023-39631](https://insights.sbomify.com/CVE-2023-39631/): Langchain vulnerable to arbitrary code execution via the evaluate function in the numexpr library (critical 9.8)
- [CVE-2023-36281](https://insights.sbomify.com/CVE-2023-36281/): langchain vulnerable to arbitrary code execution (critical 9.8)
- [CVE-2023-38896](https://insights.sbomify.com/CVE-2023-38896/): LangChain vulnerable to arbitrary code execution (critical 9.8)
- [CVE-2023-39659](https://insights.sbomify.com/CVE-2023-39659/): LangChain vulnerable to arbitrary code execution (critical 9.8)
- [CVE-2023-36095](https://insights.sbomify.com/CVE-2023-36095/): langchain Code Injection vulnerability (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-38860 and fix it if it is affected.

What it is: CVE-2023-38860 is a critical code injection vulnerability in n/a, published on 15 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-38860 exists.

Affected packages and fixed versions:
- langchain (PyPI): affected all versions; fixed in 0.0.247
- langchain (PyPI): affected all versions; fixed in 0.0.247
- langchain (PyPI): affected all versions; fixed in 0.0.247

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-38860/ (Markdown: https://insights.sbomify.com/CVE-2023-38860/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-38860
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-38860
- OSV: https://osv.dev/vulnerability/CVE-2023-38860

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-38860/
Summaries are generated and may contain mistakes; the official description above is the record.
