# CVE-2023-38887: File Upload vulnerability in Dolibarr ERP CRM

> Remote attackers can execute arbitrary code and access sensitive data via file upload flaws in Dolibarr ERP CRM.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Sep 2023
- **Updated:** 9 Jul 2026
- **Also known as:** BIT-dolibarr-2023-38887, GHSA-g8h7-mcp6-pf47, UBUNTU-CVE-2023-38887

## What is CVE-2023-38887?

CVE-2023-38887 is a high-severity vulnerability in Dolibarr Dolibarr Erp\/Crm, published on 20 Sep 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

File Upload vulnerability in Dolibarr ERP CRM v.17.0.1 and before allows a remote attacker to execute arbitrary code and obtain sensitive information via the extension filtering and renaming functions.

Weakness: CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2023-38887?

3 open source packages ship an affected version, including dolibarr/dolibarr and dolibarr. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dolibarr/dolibarr` | Packagist | All versions | 17.0.1 |
| `dolibarr/dolibarr` | Packagist | All versions | 17.0.1 |
| `dolibarr` | Bitnami | All versions to 17.0.1 | None |

Products: Dolibarr Dolibarr Erp\/Crm.

## How do I fix CVE-2023-38887?

Upgrade dolibarr/dolibarr to 17.0.1 or later.

## Is CVE-2023-38887 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-38887 exists.

## Other vulnerabilities in Dolibarr Dolibarr Erp\/Crm

- [CVE-2022-43138](https://insights.sbomify.com/CVE-2022-43138/): Dolibarr vulnerable to privilege escalation (critical 9.8)
- [CVE-2022-40871](https://insights.sbomify.com/CVE-2022-40871/): Dolibarr vulnerable to Eval Injection (critical 9.8)
- [CVE-2021-33816](https://insights.sbomify.com/CVE-2021-33816/): Dolibarr remote PHP code execution (critical 9.8)
- [CVE-2020-7995](https://insights.sbomify.com/CVE-2020-7995/): Dolibarr Improper Restriction of Excessive Authentication Attempts (critical 9.8)
- [CVE-2013-2091](https://insights.sbomify.com/CVE-2013-2091/): SQL injection in dolibarr (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-38887 and fix it if it is affected.

What it is: CVE-2023-38887 is a high-severity vulnerability in Dolibarr Dolibarr Erp\/Crm, published on 20 Sep 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-38887 exists.

Affected packages and fixed versions:
- dolibarr/dolibarr (Packagist): affected all versions; fixed in 17.0.1
- dolibarr/dolibarr (Packagist): affected all versions; fixed in 17.0.1
- dolibarr (Bitnami): affected all versions up to 17.0.1; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-38887/ (Markdown: https://insights.sbomify.com/CVE-2023-38887/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-38887
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-38887
- OSV: https://osv.dev/vulnerability/CVE-2023-38887

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-38887/
Summaries are generated and may contain mistakes; the official description above is the record.
