# CVE-2023-39010: Code injection in BoofCV

> Attackers can execute arbitrary code by tricking users into loading a malicious camera calibration file in BoofCV.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Jul 2023
- **Updated:** 22 Oct 2024
- **Also known as:** GHSA-99p5-qpqx-mhwc

## What is CVE-2023-39010?

CVE-2023-39010 is a critical code injection vulnerability in n/a, published on 28 Jul 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

BoofCV 0.42 was discovered to contain a code injection vulnerability via the component boofcv.io.calibration.CalibrationIO.load. This vulnerability is exploited by loading a crafted camera calibration file.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2023-39010?

2 open source packages ship an affected version, including org.boofcv:boofcv-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.boofcv:boofcv-core` | Maven | All versions | 0.43.1 |
| `org.boofcv:boofcv-core` | Maven | All versions | 0.43.1 |

Products: Boofcv Boofcv.

## How do I fix CVE-2023-39010?

Upgrade org.boofcv:boofcv-core to 0.43.1 or later.

## Is CVE-2023-39010 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-39010 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-39010 and fix it if it is affected.

What it is: CVE-2023-39010 is a critical code injection vulnerability in n/a, published on 28 Jul 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-39010 exists.

Affected packages and fixed versions:
- org.boofcv:boofcv-core (Maven): affected all versions; fixed in 0.43.1
- org.boofcv:boofcv-core (Maven): affected all versions; fixed in 0.43.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-39010/ (Markdown: https://insights.sbomify.com/CVE-2023-39010/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-39010
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-39010
- OSV: https://osv.dev/vulnerability/CVE-2023-39010

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-39010/
Summaries are generated and may contain mistakes; the official description above is the record.
