# CVE-2023-39020: Code injection in stanford-parser

> Attackers can execute arbitrary code via unchecked arguments in the Stanford Parser library, requiring developers to upgrade to a patched version.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Jul 2023
- **Updated:** 22 Oct 2024
- **Also known as:** GHSA-353m-jh2m-72v4

## What is CVE-2023-39020?

CVE-2023-39020 is a critical code injection vulnerability in n/a, published on 28 Jul 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

stanford-parser v3.9.2 and below was discovered to contain a code injection vulnerability in the component edu.stanford.nlp.io.getBZip2PipedInputStream. This vulnerability is exploited via passing an unchecked argument.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2023-39020?

2 open source packages ship an affected version, including edu.stanford.nlp:stanford-parser. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `edu.stanford.nlp:stanford-parser` | Maven | All versions | 4.5.5 |
| `edu.stanford.nlp:stanford-parser` | Maven | All versions | 4.5.5 |

Products: Stanford Stanford Parser.

## How do I fix CVE-2023-39020?

Upgrade edu.stanford.nlp:stanford-parser to 4.5.5 or later.

## Is CVE-2023-39020 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-39020 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-39020 and fix it if it is affected.

What it is: CVE-2023-39020 is a critical code injection vulnerability in n/a, published on 28 Jul 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-39020 exists.

Affected packages and fixed versions:
- edu.stanford.nlp:stanford-parser (Maven): affected all versions; fixed in 4.5.5
- edu.stanford.nlp:stanford-parser (Maven): affected all versions; fixed in 4.5.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-39020/ (Markdown: https://insights.sbomify.com/CVE-2023-39020/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-39020
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-39020
- OSV: https://osv.dev/vulnerability/CVE-2023-39020

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-39020/
Summaries are generated and may contain mistakes; the official description above is the record.
