CVE-2023-3904 Improper Validation of Specified Type of Input in GitLab

Medium 4.3 Published Updated

An attacker can overflow time spent on an issue to alter displayed details in issue boards, requiring permissions to modify issues.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-3904?

CVE-2023-3904 is a medium-severity vulnerability in Gitlab Gitlab, published on 15 Dec 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An issue has been discovered in GitLab EE affecting all versions starting before 16.4.4, all versions starting from 16.5 before 16.5.4, all versions starting from 16.6 before 16.6.2. It was possible to overflow the time spent on an issue that altered the details shown in the issue boards.

Weakness: CWE-1287

Which versions are affected by CVE-2023-3904?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiAll versions16.4.4, 16.5.4, 16.6.2

Products include Gitlab Gitlab.

How do I fix CVE-2023-3904?

Upgrade gitlab to a fixed version for your release line: 16.4.4, 16.5.4 or 16.6.2.

Is CVE-2023-3904 being exploited?

There is no known exploitation of CVE-2023-3904 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2023-3904, GHSA-625m-28mg-rq98, UBUNTU-CVE-2023-3904.

Is CVE-2023-3904 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free