CVE-2023-3906 Improper Validation of Specified Type of Input in GitLab

Low 3.5 Published Updated

Authenticated attackers can bypass GitLab's asset proxy by crafting malicious image URLs, potentially exposing internal resources or violating security policies.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2023-3906?

CVE-2023-3906 is a low-severity vulnerability in Gitlab Gitlab, published on 29 Sep 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

An input validation issue in the asset proxy in GitLab EE, affecting all versions from 12.3 prior to 16.2.8, 16.3 prior to 16.3.5, and 16.4 prior to 16.4.1, allowed an authenticated attacker to craft image urls which bypass the asset proxy.

Weakness: CWE-1287

Which versions are affected by CVE-2023-3906?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 12.3.016.2.8, 16.3.5, 16.4.1

Products include Gitlab Gitlab.

How do I fix CVE-2023-3906?

Upgrade gitlab to a fixed version for your release line: 16.2.8, 16.3.5 or 16.4.1.

Is CVE-2023-3906 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-3906 exists.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2023-3906, GHSA-x2v6-6q9m-6qx9.

Is CVE-2023-3906 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free