{"answers":{"affected":"2 open source packages ship an affected version, including spipu/html2pdf. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-39062 exists.","fix":"Upgrade spipu/html2pdf to 5.2.8 or later.","what":"CVE-2023-39062 is a medium-severity cross-site scripting vulnerability in n/a, published on 28 Aug 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-39062 and fix it if it is affected.\n\nWhat it is: CVE-2023-39062 is a medium-severity cross-site scripting vulnerability in n/a, published on 28 Aug 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-39062 exists.\n\nAffected packages and fixed versions:\n- spipu/html2pdf (Packagist): affected all versions; fixed in 5.2.8\n- spipu/html2pdf (Packagist): affected all versions; fixed in 5.2.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-39062/ (Markdown: https://insights.sbomify.com/CVE-2023-39062/index.md)","id":"CVE-2023-39062","markdown":"https://insights.sbomify.com/CVE-2023-39062/index.md","name":"CVE-2023-39062","record":{"aliases":["GHSA-99fg-2h75-m92h"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"HTML2PDF library","requires_auth":"none","summary":"A remote attacker can execute arbitrary code via a crafted script in the HTML2PDF library's forms.php file.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"html2pdf","vendor":"html2pdf_project"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Cross Site Scripting vulnerability in Spipu HTML2PDF before v.5.2.8 allows a remote attacker to execute arbitrary code via a crafted script to the forms.php.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":"2023-08-23","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2023-08-23T21:07:24Z","kind":"github_poc","ref":"https://github.com/afine-com/CVE-2023-39062","stars":0,"title":"Spipu Html2Pdf \u003c 5.2.8 - XSS vulnerabilities in example files"}],"tier":"weaponised"},"has_fix":true,"headline":"Spipu HTML2PDF vulnerable to cross-site scripting","id":"CVE-2023-39062","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2023"},"n_packages":2,"n_references":3,"next":{"headline":"Memory corruption in n/a","id":"CVE-2023-39063"},"packages":[{"ecosystem":"Packagist","fixed":["5.2.8"],"introduced":["0"],"last_affected":[],"package":"spipu/html2pdf","purl":null,"source":"GHSA-99fg-2h75-m92h"},{"ecosystem":"Packagist","fixed":["5.2.8"],"introduced":["0"],"last_affected":[],"package":"spipu/html2pdf","purl":"pkg:composer/spipu/html2pdf","source":"GHSA-99fg-2h75-m92h"}],"prev":{"headline":"Cross-site request forgery in n/a","id":"CVE-2023-39061"},"products":["n/a"],"published":"2023-08-28","related":[{"cvss_score":8.8,"headline":"Cross-site Scripting in HTML2PDF","id":"CVE-2021-45394","kev_date_added":null,"published":"2022-01-18"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-10-02","vendors":["n/a"]},"summary":"A remote attacker can execute arbitrary code via a crafted script in the HTML2PDF library's forms.php file.","url":"https://insights.sbomify.com/CVE-2023-39062/"}