CVE-2023-3909 Inefficient Regular Expression Complexity in GitLab

Medium 4.3 Published Updated

Attackers can cause a denial of service in GitLab by submitting a large string in the timeout input of a CI configuration file.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-3909?

CVE-2023-3909 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 6 Nov 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An issue has been discovered in GitLab CE/EE affecting all versions starting from 12.3 before 16.3.6, all versions starting from 16.4 before 16.4.2, all versions starting from 16.5 before 16.5.1. A Regular Expression Denial of Service was possible by adding a large string in timeout input in gitlab-ci.yml file.

Weakness: CWE-1333

Which versions are affected by CVE-2023-3909?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 12.3.016.3.6, 16.4.2, 16.5.1

Products include Gitlab Gitlab.

How do I fix CVE-2023-3909?

Upgrade gitlab to a fixed version for your release line: 16.3.6, 16.4.2 or 16.5.1.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2023-3909 being exploited?

There is no known exploitation of CVE-2023-3909 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2023-3909, GHSA-8mrc-cw5j-72jw, UBUNTU-CVE-2023-3909.

Is CVE-2023-3909 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free