{"answers":{"affected":"2 open source packages ship an affected version, including archive. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-39137 exists.","fix":"Upgrade archive to 3.3.8 or later.","what":"CVE-2023-39137 is a high-severity vulnerability in n/a, published on 30 Aug 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-39137 and fix it if it is affected.\n\nWhat it is: CVE-2023-39137 is a high-severity vulnerability in n/a, published on 30 Aug 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-39137 exists.\n\nAffected packages and fixed versions:\n- archive (Pub): affected all versions; fixed in 3.3.8\n- archive (Pub): affected all versions; fixed in 3.3.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-39137/ (Markdown: https://insights.sbomify.com/CVE-2023-39137/index.md)","id":"CVE-2023-39137","markdown":"https://insights.sbomify.com/CVE-2023-39137/index.md","name":"CVE-2023-39137","record":{"aliases":["GHSA-r285-q736-9v95"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Dart archive library","requires_auth":"none","summary":"Attackers can spoof zip filenames causing inconsistent parsing, potentially leading to data modification issues in applications using the Dart archive library.","user_interaction":"required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"archive","vendor":"archive_project"}],"cvss":{"score":7.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"An issue in Archive v3.3.7 allows attackers to spoof zip filenames which can lead to inconsistent filename parsing.","ecosystems":["Pub"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Filename spoofing in archive","id":"CVE-2023-39137","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"other","year":"2023"},"n_packages":2,"n_references":4,"next":{"headline":"Path traversal in ZIPFoundation","id":"CVE-2023-39138"},"packages":[{"ecosystem":"Pub","fixed":["3.3.8"],"introduced":["0"],"last_affected":[],"package":"archive","purl":null,"source":"GHSA-r285-q736-9v95"},{"ecosystem":"Pub","fixed":["3.3.8"],"introduced":["0"],"last_affected":[],"package":"archive","purl":"pkg:pub/archive","source":"GHSA-r285-q736-9v95"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2023-39136"},"products":["n/a"],"published":"2023-08-30","related":[{"cvss_score":7.8,"headline":"Path traversal in Archive","id":"CVE-2023-39139","kev_date_added":null,"published":"2023-08-30"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-10-01","vendors":["n/a"]},"summary":"Attackers can spoof zip filenames causing inconsistent parsing, potentially leading to data modification issues in applications using the Dart archive library.","url":"https://insights.sbomify.com/CVE-2023-39137/"}