# CVE-2023-39137: Filename spoofing in archive

> Attackers can spoof zip filenames causing inconsistent parsing, potentially leading to data modification issues in applications using the Dart archive library.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 30 Aug 2023
- **Updated:** 1 Oct 2024
- **Also known as:** GHSA-r285-q736-9v95

## What is CVE-2023-39137?

CVE-2023-39137 is a high-severity vulnerability in n/a, published on 30 Aug 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

An issue in Archive v3.3.7 allows attackers to spoof zip filenames which can lead to inconsistent filename parsing.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2023-39137?

2 open source packages ship an affected version, including archive. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `archive` | Pub | All versions | 3.3.8 |
| `archive` | Pub | All versions | 3.3.8 |

Products: Archive Project Archive.

## How do I fix CVE-2023-39137?

Upgrade archive to 3.3.8 or later.

## Is CVE-2023-39137 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-39137 exists.

## Other vulnerabilities in n/a

- [CVE-2023-39139](https://insights.sbomify.com/CVE-2023-39139/): Path traversal in Archive (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-39137 and fix it if it is affected.

What it is: CVE-2023-39137 is a high-severity vulnerability in n/a, published on 30 Aug 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-39137 exists.

Affected packages and fixed versions:
- archive (Pub): affected all versions; fixed in 3.3.8
- archive (Pub): affected all versions; fixed in 3.3.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-39137/ (Markdown: https://insights.sbomify.com/CVE-2023-39137/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-39137
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-39137
- OSV: https://osv.dev/vulnerability/CVE-2023-39137

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-39137/
Summaries are generated and may contain mistakes; the official description above is the record.
