# CVE-2023-39138: Path traversal in ZIPFoundation

> Attackers can execute path traversal attacks by extracting a crafted zip file using the ZIPFoundation library.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 30 Aug 2023
- **Updated:** 2 Oct 2024
- **Also known as:** GHSA-c2cc-3569-6jh2

## What is CVE-2023-39138?

CVE-2023-39138 is a high-severity path traversal vulnerability in n/a, published on 30 Aug 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

An issue in ZIPFoundation v0.9.16 allows attackers to execute a path traversal via extracting a crafted zip file.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2023-39138?

2 open source packages ship an affected version, including github.com/weichsel/ZIPFoundation. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/weichsel/ZIPFoundation` | SwiftURL | All versions | 0.9.18 |
| `github.com/weichsel/ZIPFoundation` | SwiftURL | All versions | 0.9.18 |

Products: Peakstep Zipfoundation.

## How do I fix CVE-2023-39138?

Upgrade github.com/weichsel/ZIPFoundation to 0.9.18 or later.

## Is CVE-2023-39138 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-39138 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-39138 and fix it if it is affected.

What it is: CVE-2023-39138 is a high-severity path traversal vulnerability in n/a, published on 30 Aug 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-39138 exists.

Affected packages and fixed versions:
- github.com/weichsel/ZIPFoundation (SwiftURL): affected all versions; fixed in 0.9.18
- github.com/weichsel/ZIPFoundation (SwiftURL): affected all versions; fixed in 0.9.18

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-39138/ (Markdown: https://insights.sbomify.com/CVE-2023-39138/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-39138
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-39138
- OSV: https://osv.dev/vulnerability/CVE-2023-39138

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-39138/
Summaries are generated and may contain mistakes; the official description above is the record.
