CVE-2023-3914 Incorrect User Management in GitLab
Attackers can access internal projects because service accounts are not deleted when namespaces are removed, exposing sensitive data.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-3914?
CVE-2023-3914 is a medium-severity vulnerability in Gitlab Gitlab, published on 29 Sep 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
A business logic error in GitLab EE affecting all versions prior to 16.2.8, 16.3 prior to 16.3.5, and 16.4 prior to 16.4.1 allows access to internal projects. A service account is not deleted when a namespace is deleted, allowing access to internal projects.
Weakness: CWE-286
Which versions are affected by CVE-2023-3914?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | All versions | 16.2.8, 16.3.5, 16.4.1 |
Products include Gitlab Gitlab.
How do I fix CVE-2023-3914?
Upgrade gitlab to a fixed version for your release line: 16.2.8, 16.3.5 or 16.4.1.
Is CVE-2023-3914 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-3914 exists.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2023-3914, GHSA-6f6c-487w-2449.