CVE-2023-3915 Incorrect Execution-Assigned Permissions in GitLab

Medium 6.5 Published Updated

External users with owner roles can escalate privileges by creating service accounts to access internal projects.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-3915?

CVE-2023-3915 is a medium-severity vulnerability in Gitlab Gitlab, published on 1 Sep 2023. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

An issue has been discovered in GitLab EE affecting all versions starting from 16.1 before 16.1.5, all versions starting from 16.2 before 16.2.5, all versions starting from 16.3 before 16.3.1. If an external user is given an owner role on any group, that external user may escalate their privileges on the instance by creating a service account in that group. This service account is not classified as external and may be used to access internal projects.

Weakness: CWE-732, CWE-279

Which versions are affected by CVE-2023-3915?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 16.1.016.1.5, 16.2.5, 16.3.1

Products include Gitlab Gitlab.

How do I fix CVE-2023-3915?

Upgrade gitlab to a fixed version for your release line: 16.1.5, 16.2.5 or 16.3.1.

Is CVE-2023-3915 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-3915 exists.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2023-3915, GHSA-3m8p-28cp-6cg5.

Is CVE-2023-3915 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free