CVE-2023-39151 Jenkins Stored Cross-site Scripting vulnerability
Attackers can inject malicious scripts into Jenkins build logs, leading to stored XSS and potential session hijacking or code execution.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2023-39151?
CVE-2023-39151 is a medium-severity cross-site scripting vulnerability in Jenkins Jenkins, published on 26 Jul 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Jenkins 2.415 and earlier, LTS 2.401.2 and earlier does not sanitize or properly encode URLs in build logs when transforming them into hyperlinks, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to control build log contents.
Weakness: CWE-79
Which versions are affected by CVE-2023-39151?
7 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core and jenkins. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.jenkins-ci.main:jenkins-core Maven | All versions | 2.401.3 |
org.jenkins-ci.main:jenkins-core Maven | All versions | 2.401.3 |
org.jenkins-ci.main:jenkins-core Maven | From 2.402 | 2.414.1 |
org.jenkins-ci.main:jenkins-core Maven | From 2.402 | 2.414.1 |
org.jenkins-ci.main:jenkins-core Maven | From 2.415 | 2.416 |
org.jenkins-ci.main:jenkins-core Maven | From 2.415 | 2.416 |
1 more packages
jenkins Bitnami | All versions | 2.415.1 |
Products include Jenkins Jenkins.
How do I fix CVE-2023-39151?
Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.401.3, 2.414.1 or 2.416.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2023-39151 being exploited?
There is no known exploitation of CVE-2023-39151 in the wild and no public exploit code.
Other vulnerabilities in Jenkins Jenkins
- CVE-2024-23897 Jenkins Command Line Interface (CLI) Path Traversal
- CVE-2018-1000861 Jenkins Stapler Web Framework Deserialization of Untrusted Data
- CVE-2017-1000353 Jenkins Remote Code Execution
- CVE-2015-5317 Jenkins User Interface (UI) Information Disclosure
- CVE-2021-21690 Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins
Sources
Also known as BIT-jenkins-2023-39151, GHSA-69vw-3pcm-84rw.