# CVE-2023-39151: Jenkins Stored Cross-site Scripting vulnerability

> Attackers can inject malicious scripts into Jenkins build logs, leading to stored XSS and potential session hijacking or code execution.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Jul 2023
- **Updated:** 21 Oct 2024
- **Also known as:** BIT-jenkins-2023-39151, GHSA-69vw-3pcm-84rw

## What is CVE-2023-39151?

CVE-2023-39151 is a medium-severity cross-site scripting vulnerability in Jenkins Jenkins, published on 26 Jul 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Jenkins 2.415 and earlier, LTS 2.401.2 and earlier does not sanitize or properly encode URLs in build logs when transforming them into hyperlinks, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to control build log contents.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-39151?

7 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core and jenkins. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.401.3 |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.401.3 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.402 | 2.414.1 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.402 | 2.414.1 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.415 | 2.416 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.415 | 2.416 |
| `jenkins` | Bitnami | All versions | 2.415.1 |

Products: Jenkins Jenkins.

## How do I fix CVE-2023-39151?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.401.3, 2.414.1 or 2.416.

## Is CVE-2023-39151 being exploited?

There is no known exploitation of CVE-2023-39151 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Jenkins

- [CVE-2024-23897](https://insights.sbomify.com/CVE-2024-23897/): Jenkins Command Line Interface (CLI) Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2018-1000861](https://insights.sbomify.com/CVE-2018-1000861/): Jenkins Stapler Web Framework Deserialization of Untrusted Data (critical 9.8, exploited in the wild)
- [CVE-2017-1000353](https://insights.sbomify.com/CVE-2017-1000353/): Jenkins Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2015-5317](https://insights.sbomify.com/CVE-2015-5317/): Jenkins User Interface (UI) Information Disclosure (high 7.5, exploited in the wild)
- [CVE-2021-21690](https://insights.sbomify.com/CVE-2021-21690/): Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-39151 and fix it if it is affected.

What it is: CVE-2023-39151 is a medium-severity cross-site scripting vulnerability in Jenkins Jenkins, published on 26 Jul 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-39151 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.401.3
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.401.3
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.402; fixed in 2.414.1
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.402; fixed in 2.414.1
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.415; fixed in 2.416
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.415; fixed in 2.416
- jenkins (Bitnami): affected all versions; fixed in 2.415.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-39151/ (Markdown: https://insights.sbomify.com/CVE-2023-39151/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-39151
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-39151
- OSV: https://osv.dev/vulnerability/CVE-2023-39151

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-39151/
Summaries are generated and may contain mistakes; the official description above is the record.
