# CVE-2023-39152: Incorrect control flow in Jenkins Gradle Plugin breaks credentials masking in the build log

> Attackers can view unmasked credentials in build logs due to incorrect control flow in the Jenkins Gradle Plugin.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Jul 2023
- **Updated:** 23 Oct 2024
- **Also known as:** GHSA-pvjf-4hfg-wr84

## What is CVE-2023-39152?

CVE-2023-39152 is a medium-severity vulnerability in Jenkins Gradle Plugin, published on 26 Jul 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Always-incorrect control flow implementation in Jenkins Gradle Plugin 2.8 may result in credentials not being masked (i.e., replaced with asterisks) in the build log in some circumstances.

Weakness: CWE-670 (Always-Incorrect Control Flow Implementation)

## Which versions are affected by CVE-2023-39152?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:gradle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:gradle` | Maven | All versions | 2.8.1 |
| `org.jenkins-ci.plugins:gradle` | Maven | All versions | 2.8.1 |

Products: Jenkins Gradle.

## How do I fix CVE-2023-39152?

Upgrade org.jenkins-ci.plugins:gradle to 2.8.1 or later.

## Is CVE-2023-39152 being exploited?

There is no known exploitation of CVE-2023-39152 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-39152 and fix it if it is affected.

What it is: CVE-2023-39152 is a medium-severity vulnerability in Jenkins Gradle Plugin, published on 26 Jul 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-39152 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:gradle (Maven): affected all versions; fixed in 2.8.1
- org.jenkins-ci.plugins:gradle (Maven): affected all versions; fixed in 2.8.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-39152/ (Markdown: https://insights.sbomify.com/CVE-2023-39152/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-39152
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-39152
- OSV: https://osv.dev/vulnerability/CVE-2023-39152

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-39152/
Summaries are generated and may contain mistakes; the official description above is the record.
