CVE-2023-3917 Improper Validation of Specified Type of Input in GitLab

Medium 4.3 Published Updated

An attacker can cause GitLab pipelines to fail, resulting in a denial of service for CI/CD operations.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-3917?

CVE-2023-3917 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 29 Sep 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Denial of Service in pipelines affecting all versions of Gitlab EE and CE prior to 16.2.8, 16.3 prior to 16.3.5, and 16.4 prior to 16.4.1 allows attacker to cause pipelines to fail.

Weakness: CWE-1287

Which versions are affected by CVE-2023-3917?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiAll versions16.2.8, 16.3.5, 16.4.1

Products include Gitlab Gitlab.

How do I fix CVE-2023-3917?

Upgrade gitlab to a fixed version for your release line: 16.2.8, 16.3.5 or 16.4.1.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2023-3917 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-3917 exists.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2023-3917, GHSA-7jqp-vcg7-7x84, UBUNTU-CVE-2023-3917.

Is CVE-2023-3917 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free