CVE-2023-3932 Incorrect User Management in GitLab
Attackers can execute pipeline jobs as arbitrary users via scheduled security scan policies in GitLab EE, requiring immediate upgrade.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-3932?
CVE-2023-3932 is a high-severity vulnerability in Gitlab Gitlab, published on 3 Aug 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
An issue has been discovered in GitLab EE affecting all versions starting from 13.12 before 16.0.8, all versions starting from 16.1 before 16.1.3, all versions starting from 16.2 before 16.2.2. It was possible for an attacker to run pipeline jobs as an arbitrary user via scheduled security scan policies.
Weakness: CWE-286
Which versions are affected by CVE-2023-3932?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 13.12.0 | 16.0.8, 16.1.3, 16.2.2 |
Products include Gitlab Gitlab.
How do I fix CVE-2023-3932?
Upgrade gitlab to a fixed version for your release line: 16.0.8, 16.1.3 or 16.2.2.
Is CVE-2023-3932 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-3932 exists.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2023-3932, GHSA-vvcp-5v5p-8jhc.