{"answers":{"affected":"2 open source packages ship an affected version, including node and node-min. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-39331 in the wild and no public exploit code.","fix":"Upgrade node to 20.8.1 or later.","what":"CVE-2023-39331 is a high-severity path traversal vulnerability in Nodejs Node.js, published on 18 Oct 2023. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-39331 and fix it if it is affected.\n\nWhat it is: CVE-2023-39331 is a high-severity path traversal vulnerability in Nodejs Node.js, published on 18 Oct 2023. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-39331 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- node (Bitnami): affected from 20.0.0; fixed in 20.8.1\n- node-min (Bitnami): affected from 20.0.0; fixed in 20.8.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-39331/ (Markdown: https://insights.sbomify.com/CVE-2023-39331/index.md)","id":"CVE-2023-39331","markdown":"https://insights.sbomify.com/CVE-2023-39331/index.md","name":"CVE-2023-39331","record":{"aliases":["BIT-node-2023-39331","BIT-node-min-2023-39331","GHSA-7xrv-q25v-f95m"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["data_read","data_modify"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"Node.js runtime","requires_auth":"none","summary":"Attackers can exploit path traversal in Node.js by overwriting built-in utility functions, potentially reading or modifying files.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"node.js","vendor":"nodejs"}],"cvss":{"score":7.7,"severity":"high","source":"cna","vector":"CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N","version":"3.0"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"A previously disclosed vulnerability (CVE-2023-30584) was patched insufficiently in commit 205f1e6. The new path traversal vulnerability arises because the implementation does not protect itself against the application overwriting built-in utility functions with user-defined implementations.\n\nPlease note that at the time this CVE was issued, the permission model is an experimental feature of Node.js.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Path traversal in Node","id":"CVE-2023-39331","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"nodejs:node.js","products":["nodejs:node.js"],"type":"path_traversal","year":"2023"},"n_packages":2,"n_references":2,"next":{"headline":"Path traversal in Node","id":"CVE-2023-39332"},"packages":[{"ecosystem":"Bitnami","fixed":["20.8.1"],"introduced":["20.0.0"],"last_affected":[],"package":"node","purl":"pkg:bitnami/node","source":"BIT-node-2023-39331"},{"ecosystem":"Bitnami","fixed":["20.8.1"],"introduced":["20.0.0"],"last_affected":[],"package":"node-min","purl":"pkg:bitnami/node-min","source":"BIT-node-min-2023-39331"}],"prev":{"headline":"Openjpeg: resource exhaustion will occur in the opj_t1_decode_cblks function in the tcd.c","id":"CVE-2023-39329"},"products":["Node"],"published":"2023-10-18","related":[{"cvss_score":9.8,"headline":"Security feature bypass in Node","id":"CVE-2023-32002","kev_date_added":null,"published":"2023-08-21"},{"cvss_score":9.8,"headline":"Integer overflow in n/a","id":"CVE-2016-6303","kev_date_added":null,"published":"2016-09-16"},{"cvss_score":9.1,"headline":"Security feature bypass in Node.js","id":"CVE-2017-15896","kev_date_added":null,"published":"2017-12-11"},{"cvss_score":8.8,"headline":"Server-side request forgery in Node.js","id":"CVE-2018-7160","kev_date_added":null,"published":"2018-05-17"},{"cvss_score":8.1,"headline":"Misconfiguration in Node.js","id":"CVE-2018-12120","kev_date_added":null,"published":"2018-11-28"},{"cvss_score":7.9,"headline":"Path traversal in Node","id":"CVE-2024-21891","kev_date_added":null,"published":"2024-02-20"},{"cvss_score":7.9,"headline":"Path traversal in Node","id":"CVE-2024-21896","kev_date_added":null,"published":"2024-02-20"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-11-03","vendors":["NodeJS"]},"summary":"Attackers can exploit path traversal in Node.js by overwriting built-in utility functions, potentially reading or modifying files.","url":"https://insights.sbomify.com/CVE-2023-39331/"}