{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-39342 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2023-39342 yet. Limit exposure of the affected software until one is available.","what":"CVE-2023-39342 is a low-severity vulnerability in freedomofpress dangerzone, published on 8 Aug 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-39342 and fix it if it is affected.\n\nWhat it is: CVE-2023-39342 is a low-severity vulnerability in freedomofpress dangerzone, published on 8 Aug 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-39342 in the wild and no public exploit code.\n\nAffected product: freedomofpress dangerzone. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-39342/ (Markdown: https://insights.sbomify.com/CVE-2023-39342/index.md)","id":"CVE-2023-39342","markdown":"https://insights.sbomify.com/CVE-2023-39342/index.md","name":"CVE-2023-39342","record":{"aliases":["GHSA-pvwq-6vpp-2632"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["other"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Document sanitization tool","requires_auth":"none","summary":"Attackers can spoof terminal messages or change window titles via unsanitized ANSI escape sequences in Dangerzone CLI output.","user_interaction":"required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"dangerzone","vendor":"freedom"}],"cvss":{"score":3.6,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-150","name":"Improper Neutralization of Escape, Meta, or Control Sequences"}],"description":"Dangerzone is software for converting potentially dangerous PDFs, office documents, or images to safe PDFs. The Dangerzone CLI (`dangerzone-cli` command) logs output from the container where the file sanitization takes place, to the user's terminal. Prior to version 0.4.2, if the container is compromised and can return attacker-controlled strings, then the attacker may be able to spoof messages in the user's terminal or change the window title. Besides logging output from containers, it also logs the names of the files it sanitizes. If these files contain ANSI escape sequences, then the same issue applies. Dangerzone is predominantly a GUI application, so this issue should leave most of our users unaffected. Nevertheless, we always suggest updating to the newest version. This issue is fixed in Dangerzone 0.4.2.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Dangerzone CLI does not sanitize ANSI escape characters","id":"CVE-2023-39342","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"other","year":"2023"},"n_packages":0,"n_references":3,"next":{"headline":"Sulu Observable Response Discrepancy on Admin Login","id":"CVE-2023-39343"},"packages":[],"prev":{"headline":"Denial of service in ActSecure χ","id":"CVE-2023-39341"},"products":["dangerzone"],"published":"2023-08-08","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-10-04","vendors":["freedomofpress"]},"summary":"Attackers can spoof terminal messages or change window titles via unsanitized ANSI escape sequences in Dangerzone CLI output.","url":"https://insights.sbomify.com/CVE-2023-39342/"}