# CVE-2023-39342: Dangerzone CLI does not sanitize ANSI escape characters

> Attackers can spoof terminal messages or change window titles via unsanitized ANSI escape sequences in Dangerzone CLI output.

- **Severity:** Low 3.6 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 8 Aug 2023
- **Updated:** 4 Oct 2024
- **Also known as:** GHSA-pvwq-6vpp-2632

## What is CVE-2023-39342?

CVE-2023-39342 is a low-severity vulnerability in freedomofpress dangerzone, published on 8 Aug 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Dangerzone is software for converting potentially dangerous PDFs, office documents, or images to safe PDFs. The Dangerzone CLI (`dangerzone-cli` command) logs output from the container where the file sanitization takes place, to the user's terminal. Prior to version 0.4.2, if the container is compromised and can return attacker-controlled strings, then the attacker may be able to spoof messages in the user's terminal or change the window title. Besides logging output from containers, it also logs the names of the files it sanitizes. If these files contain ANSI escape sequences, then the same issue applies. Dangerzone is predominantly a GUI application, so this issue should leave most of our users unaffected. Nevertheless, we always suggest updating to the newest version. This issue is fixed in Dangerzone 0.4.2.

Weakness: CWE-150 (Improper Neutralization of Escape, Meta, or Control Sequences)

## Which versions are affected by CVE-2023-39342?

It affects 1 product.


Products: Freedom Dangerzone.

## How do I fix CVE-2023-39342?

No fix has been published for CVE-2023-39342 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-39342 being exploited?

There is no known exploitation of CVE-2023-39342 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-39342 and fix it if it is affected.

What it is: CVE-2023-39342 is a low-severity vulnerability in freedomofpress dangerzone, published on 8 Aug 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-39342 in the wild and no public exploit code.

Affected product: freedomofpress dangerzone. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-39342/ (Markdown: https://insights.sbomify.com/CVE-2023-39342/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-39342
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-39342
- OSV: https://osv.dev/vulnerability/CVE-2023-39342

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-39342/
Summaries are generated and may contain mistakes; the official description above is the record.
