{"answers":{"affected":"3 open source packages ship an affected version, including sentry. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-39349 in the wild and no public exploit code.","fix":"Upgrade sentry to 23.7.2 or later.","what":"CVE-2023-39349 is a high-severity missing authorization vulnerability in getsentry sentry, published on 7 Aug 2023. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-39349 and fix it if it is affected.\n\nWhat it is: CVE-2023-39349 is a high-severity missing authorization vulnerability in getsentry sentry, published on 7 Aug 2023. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-39349 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- sentry (PyPI): affected from 22.1.0; fixed in 23.7.2\n- sentry (PyPI): affected from 22.1.0; fixed in 23.7.2\n- sentry (PyPI): affected from 22.1.0; fixed in 23.7.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-39349/ (Markdown: https://insights.sbomify.com/CVE-2023-39349/index.md)","id":"CVE-2023-39349","markdown":"https://insights.sbomify.com/CVE-2023-39349/index.md","name":"CVE-2023-39349","record":{"aliases":["GHSA-9jcq-jf57-c62c","PYSEC-2026-1912"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Sentry error tracking","requires_auth":"low_privilege","summary":"Attackers with low-scope tokens can list and use high-scope tokens, enabling privilege escalation and unauthorized data access in Sentry.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"sentry","vendor":"sentry"}],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-287","name":"Improper Authentication"},{"id":"CWE-284","name":"Improper Access Control"}],"description":"Sentry is an error tracking and performance monitoring platform. Starting in version 22.1.0 and prior to version 23.7.2, an attacker with access to a token with few or no scopes can query `/api/0/api-tokens/` for a list of all tokens created by a user, including tokens with greater scopes, and use those tokens in other requests. There is no evidence that the issue was exploited on `sentry.io`. For self-hosted users, it is advised to rotate user auth tokens. A fix is available in version 23.7.2 of `sentry` and `self-hosted`. There are no known workarounds.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Sentry vulnerable to privilege escalation via ApiTokensEndpoint","id":"CVE-2023-39349","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"missing_authorization","year":"2023"},"n_packages":3,"n_references":5,"next":{"headline":"Incorrect offset calculation leading to denial of service in FreeRDP","id":"CVE-2023-39350"},"packages":[{"ecosystem":"PyPI","fixed":["23.7.2"],"introduced":["22.1.0"],"last_affected":[],"package":"sentry","purl":null,"source":"GHSA-9jcq-jf57-c62c"},{"ecosystem":"PyPI","fixed":["23.7.2"],"introduced":["22.1.0"],"last_affected":[],"package":"sentry","purl":"pkg:pypi/sentry","source":"GHSA-9jcq-jf57-c62c"},{"ecosystem":"PyPI","fixed":["23.7.2"],"introduced":["22.1.0"],"last_affected":[],"package":"sentry","purl":"pkg:pypi/sentry","source":"PYSEC-2026-1912"}],"prev":{"headline":"Improper log output when using GitHub Status Notifications in spinnaker","id":"CVE-2023-39348"},"products":["sentry"],"published":"2023-08-07","related":[{"cvss_score":9.1,"headline":"Sentry: Improper authentication on SAML SSO process allows user identity linking","id":"CVE-2026-42354","kev_date_added":null,"published":"2026-05-08"},{"cvss_score":9.1,"headline":"Sentry: Improper Authentication on SAML SSO process allows user identity linking","id":"CVE-2026-27197","kev_date_added":null,"published":"2026-02-21"},{"cvss_score":8.7,"headline":"Sentry 8.2.0 Remote Code Execution via Pickle Deserialization","id":"CVE-2021-47935","kev_date_added":null,"published":"2026-05-10"},{"cvss_score":7.7,"headline":"Sentry vulnerable to improper authorization on debug and artifact file downloads","id":"CVE-2023-36826","kev_date_added":null,"published":"2023-07-25"},{"cvss_score":7.5,"headline":"Sentry: Inefficient Regular Expression Complexity in sentry","id":"CVE-2026-52794","kev_date_added":null,"published":"2026-06-24"},{"cvss_score":7.3,"headline":"Sentry's superuser cleartext password leaked in logs","id":"CVE-2024-32474","kev_date_added":null,"published":"2024-04-18"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-10-04","vendors":["getsentry"]},"summary":"Attackers with low-scope tokens can list and use high-scope tokens, enabling privilege escalation and unauthorized data access in Sentry.","url":"https://insights.sbomify.com/CVE-2023-39349/"}