# CVE-2023-39349: Sentry vulnerable to privilege escalation via ApiTokensEndpoint

> Attackers with low-scope tokens can list and use high-scope tokens, enabling privilege escalation and unauthorized data access in Sentry.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Aug 2023
- **Updated:** 4 Oct 2024
- **Also known as:** GHSA-9jcq-jf57-c62c, PYSEC-2026-1912

## What is CVE-2023-39349?

CVE-2023-39349 is a high-severity missing authorization vulnerability in getsentry sentry, published on 7 Aug 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Sentry is an error tracking and performance monitoring platform. Starting in version 22.1.0 and prior to version 23.7.2, an attacker with access to a token with few or no scopes can query `/api/0/api-tokens/` for a list of all tokens created by a user, including tokens with greater scopes, and use those tokens in other requests. There is no evidence that the issue was exploited on `sentry.io`. For self-hosted users, it is advised to rotate user auth tokens. A fix is available in version 23.7.2 of `sentry` and `self-hosted`. There are no known workarounds.

Weakness: CWE-287 (Improper Authentication), CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2023-39349?

3 open source packages ship an affected version, including sentry. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sentry` | PyPI | From 22.1.0 | 23.7.2 |
| `sentry` | PyPI | From 22.1.0 | 23.7.2 |
| `sentry` | PyPI | From 22.1.0 | 23.7.2 |

Products: Sentry Sentry.

## How do I fix CVE-2023-39349?

Upgrade sentry to 23.7.2 or later.

## Is CVE-2023-39349 being exploited?

There is no known exploitation of CVE-2023-39349 in the wild and no public exploit code.

## Other vulnerabilities in getsentry sentry

- [CVE-2026-42354](https://insights.sbomify.com/CVE-2026-42354/): Sentry: Improper authentication on SAML SSO process allows user identity linking (critical 9.1)
- [CVE-2026-27197](https://insights.sbomify.com/CVE-2026-27197/): Sentry: Improper Authentication on SAML SSO process allows user identity linking (critical 9.1)
- [CVE-2021-47935](https://insights.sbomify.com/CVE-2021-47935/): Sentry 8.2.0 Remote Code Execution via Pickle Deserialization (high 8.7)
- [CVE-2023-36826](https://insights.sbomify.com/CVE-2023-36826/): Sentry vulnerable to improper authorization on debug and artifact file downloads (high 7.7)
- [CVE-2026-52794](https://insights.sbomify.com/CVE-2026-52794/): Sentry: Inefficient Regular Expression Complexity in sentry (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-39349 and fix it if it is affected.

What it is: CVE-2023-39349 is a high-severity missing authorization vulnerability in getsentry sentry, published on 7 Aug 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-39349 in the wild and no public exploit code.

Affected packages and fixed versions:
- sentry (PyPI): affected from 22.1.0; fixed in 23.7.2
- sentry (PyPI): affected from 22.1.0; fixed in 23.7.2
- sentry (PyPI): affected from 22.1.0; fixed in 23.7.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-39349/ (Markdown: https://insights.sbomify.com/CVE-2023-39349/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-39349
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-39349
- OSV: https://osv.dev/vulnerability/CVE-2023-39349

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-39349/
Summaries are generated and may contain mistakes; the official description above is the record.
