# CVE-2023-39363: Vyper incorrectly allocated named re-entrancy locks

> Vyper compiler flaw allows cross-function re-entrancy attacks, enabling unauthorized state modification in smart contracts using specific non-reentrant patterns.

- **Severity:** Critical 9.1 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:H/VA:H/SC:N/SI:H/SA:H/E:A`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Aug 2023
- **Updated:** 11 Oct 2024
- **Also known as:** GHSA-5824-cm3x-3c38, PYSEC-2023-142

## What is CVE-2023-39363?

CVE-2023-39363 is a critical vulnerability in vyperlang vyper, published on 7 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Vyper is a Pythonic Smart Contract Language for the Ethereum Virtual Machine (EVM). In versions 0.2.15, 0.2.16 and 0.3.0, named re-entrancy locks are allocated incorrectly. Each function using a named re-entrancy lock gets a unique lock regardless of the key, allowing cross-function re-entrancy in contracts compiled with the susceptible versions. A specific set of conditions is required to result in misbehavior of affected contracts, specifically: a `.vy` contract compiled with `vyper` versions `0.2.15`, `0.2.16`, or `0.3.0`; a primary function that utilizes the `@nonreentrant` decorator with a specific `key` and does not strictly follow the check-effects-interaction pattern (i.e. contains an external call to an untrusted party before storage updates); and a secondary function that utilizes the same `key` and would be affected by the improper state caused by the primary function. Version 0.3.1 contains a fix for this issue.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2023-39363?

3 open source packages ship an affected version, including vyper. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vyper` | PyPI | All versions | None |
| `vyper` | PyPI | From 0.2.15 | 0.3.1 |
| `vyper` | PyPI | From 0.2.15 | 0.3.1 |

Products: Vyperlang Vyper.

## How do I fix CVE-2023-39363?

Upgrade vyper to 0.3.1 or later.

## Is CVE-2023-39363 being exploited?

There is no known exploitation of CVE-2023-39363 in the wild and no public exploit code.

## Other vulnerabilities in vyperlang vyper

- [CVE-2024-24563](https://insights.sbomify.com/CVE-2024-24563/): Vyper array negative index vulnerability (critical 9.8)
- [CVE-2024-24561](https://insights.sbomify.com/CVE-2024-24561/): Vyper bounds check on built-in `slice()` function can be overflowed (critical 9.8)
- [CVE-2022-24845](https://insights.sbomify.com/CVE-2022-24845/): Integer bounds error in Vyper (high 8.8)
- [CVE-2022-29255](https://insights.sbomify.com/CVE-2022-29255/): Multiple evaluation of contract address in call in vyper (high 8.2)
- [CVE-2023-42443](https://insights.sbomify.com/CVE-2023-42443/): Vyper vulnerable to memory corruption in certain builtins utilizing `msize` (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-39363 and fix it if it is affected.

What it is: CVE-2023-39363 is a critical vulnerability in vyperlang vyper, published on 7 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-39363 in the wild and no public exploit code.

Affected packages and fixed versions:
- vyper (PyPI): affected all versions; no fix listed
- vyper (PyPI): affected from 0.2.15; fixed in 0.3.1
- vyper (PyPI): affected from 0.2.15; fixed in 0.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-39363/ (Markdown: https://insights.sbomify.com/CVE-2023-39363/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-39363
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-39363
- OSV: https://osv.dev/vulnerability/CVE-2023-39363

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-39363/
Summaries are generated and may contain mistakes; the official description above is the record.
