CVE-2023-39410 Apache Avro Java SDK: Memory when deserializing untrusted data in Avro Java SDK

High 7.5 Published Updated

Attackers can cause out-of-memory errors in Java applications by sending untrusted or corrupted data to the Apache Avro deserializer.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-39410?

CVE-2023-39410 is a high-severity denial of service vulnerability in Apache Avro Java SDK, published on 29 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

When deserializing untrusted or corrupted data, it is possible for a reader to consume memory beyond the allowed constraints and thus lead to out of memory on the system.

This issue affects Java applications using Apache Avro Java SDK up to and including 1.11.2. Users should update to apache-avro version 1.11.3 which addresses this issue.

Weakness: CWE-502

Which versions are affected by CVE-2023-39410?

3 open source packages ship an affected version, including org.apache.avro:avro and avro. It affects 1 product.

PackageAffectedFixed in
org.apache.avro:avro MavenAll versions1.11.3
org.apache.avro:avro MavenAll versions1.11.3
avro PyPIAll versions1.11.3

Products include Apache Avro.

How do I fix CVE-2023-39410?

Upgrade org.apache.avro:avro to 1.11.3 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2023-39410 being exploited?

There is no known exploitation of CVE-2023-39410 in the wild and no public exploit code.

Sources

Also known as CLEANSTART-2026-OX44543, CLEANSTART-2026-WB91294, CLEANSTART-2026-XL50030, CLSA-2025-1765238872, ECHO-bc7c-eb94-5acc, GHSA-rhrv-645h-fjfh and 12 more.

Is CVE-2023-39410 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free