# CVE-2023-39410: Apache Avro Java SDK: Memory when deserializing untrusted data in Avro Java SDK

> Attackers can cause out-of-memory errors in Java applications by sending untrusted or corrupted data to the Apache Avro deserializer.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Sep 2023
- **Updated:** 13 Feb 2025
- **Also known as:** CLEANSTART-2026-OX44543, CLEANSTART-2026-WB91294, CLEANSTART-2026-XL50030, CLSA-2025-1765238872, ECHO-bc7c-eb94-5acc, GHSA-rhrv-645h-fjfh, MINI-87m2-29jp-gv28, MINI-895f-pxx5-379v, MINI-94hh-ffxr-c7r5, MINI-988j-wh4c-q7v4, MINI-vj65-387g-4rp9, OESA-2024-1809, OESA-2024-1915, OESA-2024-1916, OESA-2024-1917, OESA-2024-1918, PYSEC-2023-188, ROOT-APP-MAVEN-CVE-2023-39410

## What is CVE-2023-39410?

CVE-2023-39410 is a high-severity denial of service vulnerability in Apache Avro Java SDK, published on 29 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

When deserializing untrusted or corrupted data, it is possible for a reader to consume memory beyond the allowed constraints and thus lead to out of memory on the system.

This issue affects Java applications using Apache Avro Java SDK up to and including 1.11.2.  Users should update to apache-avro version 1.11.3 which addresses this issue.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2023-39410?

3 open source packages ship an affected version, including org.apache.avro:avro and avro. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.avro:avro` | Maven | All versions | 1.11.3 |
| `org.apache.avro:avro` | Maven | All versions | 1.11.3 |
| `avro` | PyPI | All versions | 1.11.3 |

Products: Apache Avro.

## How do I fix CVE-2023-39410?

Upgrade org.apache.avro:avro to 1.11.3 or later.

## Is CVE-2023-39410 being exploited?

There is no known exploitation of CVE-2023-39410 in the wild and no public exploit code.

## Other vulnerabilities in Apache Avro Java SDK

- [CVE-2024-47561](https://insights.sbomify.com/CVE-2024-47561/): Apache Avro Java SDK: Arbitrary Code Execution when reading Avro schema (Java SDK) (critical 9.2)
- [CVE-2022-35724](https://insights.sbomify.com/CVE-2022-35724/): Denial of service while reading data in Avro Rust SDK (high 7.5)
- [CVE-2022-36124](https://insights.sbomify.com/CVE-2022-36124/): Memory overconsumption in Avro Rust SDK (high 7.5)
- [CVE-2022-36125](https://insights.sbomify.com/CVE-2022-36125/): Integer overflow when reading corrupted .avro file in Avro Rust SDK (high 7.5)
- [CVE-2021-43045](https://insights.sbomify.com/CVE-2021-43045/): Possible DOS vulnerabilities in C# Avro SDK (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-39410 and fix it if it is affected.

What it is: CVE-2023-39410 is a high-severity denial of service vulnerability in Apache Avro Java SDK, published on 29 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-39410 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.avro:avro (Maven): affected all versions; fixed in 1.11.3
- org.apache.avro:avro (Maven): affected all versions; fixed in 1.11.3
- avro (PyPI): affected all versions; fixed in 1.11.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-39410/ (Markdown: https://insights.sbomify.com/CVE-2023-39410/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-39410
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-39410
- OSV: https://osv.dev/vulnerability/CVE-2023-39410

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-39410/
Summaries are generated and may contain mistakes; the official description above is the record.
