{"answers":{"affected":"1 open source package ship an affected version, including postgresql. It affects 3 products.","exploited":"There is no known exploitation of CVE-2023-39418 in the wild and no public exploit code.","fix":"Upgrade postgresql to 15.4.0 or later.","what":"CVE-2023-39418 is a low-severity missing authorization vulnerability in Debian Debian Linux, published on 11 Aug 2023. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-39418 and fix it if it is affected.\n\nWhat it is: CVE-2023-39418 is a low-severity missing authorization vulnerability in Debian Debian Linux, published on 11 Aug 2023. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-39418 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- postgresql (Bitnami): affected from 15.0.0; fixed in 15.4.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-39418/ (Markdown: https://insights.sbomify.com/CVE-2023-39418/index.md)","id":"CVE-2023-39418","markdown":"https://insights.sbomify.com/CVE-2023-39418/index.md","name":"CVE-2023-39418","record":{"aliases":["ALPINE-CVE-2023-39418","BIT-postgresql-2023-39418","CLEANSTART-2026-VX15761","DEBIAN-CVE-2023-39418","ECHO-108e-f2fd-6847","GHSA-chgx-7cw3-hr55"],"analysis":{"component_type":"database","fix_type":"patch","impacts":["data_modify"],"network_reachable":"yes","non_default_config":true,"product_category":"PostgreSQL database","requires_auth":"low_privilege","summary":"Attackers can bypass row security policies to insert forbidden rows using the MERGE command, requiring specific policy configurations.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"postgresql","vendor":"postgresql"},{"product":"enterprise_linux","vendor":"redhat"}],"cvss":{"score":3.1,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-1220","name":"Insufficient Granularity of Access Control"}],"description":"A vulnerability was found in PostgreSQL with the use of the MERGE command, which fails to test new rows against row security policies defined for UPDATE and SELECT. If UPDATE and SELECT policies forbid some rows that INSERT policies do not forbid, a user could store such rows.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Postgresql: merge fails to enforce update or select row security policies","id":"CVE-2023-39418","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"debian:debian_linux","products":["debian:debian_linux","postgresql:postgresql","redhat:enterprise_linux"],"type":"missing_authorization","year":"2023"},"n_packages":1,"n_references":8,"next":{"headline":"Memory corruption in Solid Edge SE2023","id":"CVE-2023-39419"},"packages":[{"ecosystem":"Bitnami","fixed":["15.4.0"],"introduced":["15.0.0"],"last_affected":[],"package":"postgresql","purl":"pkg:bitnami/postgresql","source":"BIT-postgresql-2023-39418"}],"prev":{"headline":"Postgresql: extension script @substitutions@ within quoting allow sql injection","id":"CVE-2023-39417"},"products":["Red Hat Enterprise Linux 6","Red Hat Enterprise Linux 7","Red Hat Enterprise Linux 8","Red Hat Enterprise Linux 8.8 Extended Update Support","Red Hat Enterprise Linux 9","Red Hat Enterprise Linux 9.2 Extended Update Support","Red Hat Software Collections"],"published":"2023-08-11","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-21","vendors":["Red Hat"]},"summary":"Attackers can bypass row security policies to insert forbidden rows using the MERGE command, requiring specific policy configurations.","url":"https://insights.sbomify.com/CVE-2023-39418/"}