# CVE-2023-39418: Postgresql: merge fails to enforce update or select row security policies

> Attackers can bypass row security policies to insert forbidden rows using the MERGE command, requiring specific policy configurations.

- **Severity:** Low 3.1 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Aug 2023
- **Updated:** 21 Nov 2025
- **Also known as:** ALPINE-CVE-2023-39418, BIT-postgresql-2023-39418, CLEANSTART-2026-VX15761, DEBIAN-CVE-2023-39418, ECHO-108e-f2fd-6847, GHSA-chgx-7cw3-hr55

## What is CVE-2023-39418?

CVE-2023-39418 is a low-severity missing authorization vulnerability in Debian Debian Linux, published on 11 Aug 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability was found in PostgreSQL with the use of the MERGE command, which fails to test new rows against row security policies defined for UPDATE and SELECT. If UPDATE and SELECT policies forbid some rows that INSERT policies do not forbid, a user could store such rows.

Weakness: CWE-1220 (Insufficient Granularity of Access Control)

## Which versions are affected by CVE-2023-39418?

1 open source package ship an affected version, including postgresql. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `postgresql` | Bitnami | From 15.0.0 | 15.4.0 |

Products: Debian Debian Linux, Postgresql Postgresql, Redhat Enterprise Linux.

## How do I fix CVE-2023-39418?

Upgrade postgresql to 15.4.0 or later.

## Is CVE-2023-39418 being exploited?

There is no known exploitation of CVE-2023-39418 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-39418 and fix it if it is affected.

What it is: CVE-2023-39418 is a low-severity missing authorization vulnerability in Debian Debian Linux, published on 11 Aug 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-39418 in the wild and no public exploit code.

Affected packages and fixed versions:
- postgresql (Bitnami): affected from 15.0.0; fixed in 15.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-39418/ (Markdown: https://insights.sbomify.com/CVE-2023-39418/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-39418
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-39418
- OSV: https://osv.dev/vulnerability/CVE-2023-39418

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-39418/
Summaries are generated and may contain mistakes; the official description above is the record.
