CVE-2023-39441 Apache Airflow missing Certificate Validation
Missing certificate validation in SMTP and IMAP clients allows attackers to intercept credentials and mail contents via man-in-the-middle attacks.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-39441?
CVE-2023-39441 is a medium-severity vulnerability in Apache Airflow, published on 23 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Apache Airflow SMTP Provider before 1.3.0, Apache Airflow IMAP Provider before 3.3.0, and Apache Airflow before 2.7.0 are affected by the Validation of OpenSSL Certificate vulnerability.
The default SSL context with SSL library did not check a server's X.509 certificate. Instead, the code accepted any certificate, which could result in the disclosure of mail server credentials or mail contents when the client connects to an attacker in a MITM position.
Users are strongly advised to upgrade to Apache Airflow version 2.7.0 or newer, Apache Airflow IMAP Provider version 3.3.0 or newer, and Apache Airflow SMTP Provider version 1.3.0 or newer to mitigate the risk associated with this vulnerability
Weakness: CWE-295
Which versions are affected by CVE-2023-39441?
10 open source packages ship an affected version, including apache-airflow, airflow and apache-airflow-providers-imap. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
apache-airflow PyPI | All versions | 2.7.0 |
apache-airflow PyPI | All versions | 2.7.0 |
apache-airflow PyPI | All versions | 2.7.0 |
airflow Bitnami | All versions | 2.7.0 |
apache-airflow-providers-imap PyPI | All versions | 3.3.0 |
apache-airflow-providers-imap PyPI | All versions | 3.3.0 |
4 more packages
apache-airflow-providers-imap PyPI | All versions | 3.3.0 |
apache-airflow-providers-smtp PyPI | All versions | 1.3.0 |
apache-airflow-providers-smtp PyPI | All versions | 1.3.0 |
apache-airflow-providers-smtp PyPI | All versions | 1.3.0 |
Products include Apache Airflow, Apache Apache-Airflow-Providers-Imap, Apache Apache-Airflow-Providers-Smtp.
How do I fix CVE-2023-39441?
Upgrade apache-airflow to 2.7.0 or later.
Is CVE-2023-39441 being exploited?
There is no known exploitation of CVE-2023-39441 in the wild and no public exploit code.
Other vulnerabilities in Apache Airflow
- CVE-2020-13927 Apache Airflow's Experimental API Authentication Bypass
- CVE-2020-11978 Apache Airflow Command Injection
- CVE-2026-33264 Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize()
- CVE-2023-25754 Apache Airflow: Privilege escalation using airflow logs
- CVE-2023-22884 Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow
Sources
Also known as BIT-airflow-2023-39441, GHSA-5f35-pq34-c87q, PYSEC-2026-1130, PYSEC-2026-2368, PYSEC-2026-2371.