# CVE-2023-39441: Apache Airflow missing Certificate Validation

> Missing certificate validation in SMTP and IMAP clients allows attackers to intercept credentials and mail contents via man-in-the-middle attacks.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Aug 2023
- **Updated:** 13 Feb 2025
- **Also known as:** BIT-airflow-2023-39441, GHSA-5f35-pq34-c87q, PYSEC-2026-1130, PYSEC-2026-2368, PYSEC-2026-2371

## What is CVE-2023-39441?

CVE-2023-39441 is a medium-severity vulnerability in Apache Airflow, published on 23 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache Airflow SMTP Provider before 1.3.0, Apache Airflow IMAP Provider before 3.3.0, and Apache Airflow before 2.7.0 are affected by the Validation of OpenSSL Certificate vulnerability.

The default SSL context with SSL library did not check a server's X.509 certificate.  Instead, the code accepted any certificate, which could result in the disclosure of mail server credentials or mail contents when the client connects to an attacker in a MITM position.

Users are strongly advised to upgrade to Apache Airflow version 2.7.0 or newer, Apache Airflow IMAP Provider version 3.3.0 or newer, and Apache Airflow SMTP Provider version 1.3.0 or newer to mitigate the risk associated with this vulnerability

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2023-39441?

10 open source packages ship an affected version, including apache-airflow, airflow and apache-airflow-providers-imap. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow` | PyPI | All versions | 2.7.0 |
| `apache-airflow` | PyPI | All versions | 2.7.0 |
| `apache-airflow` | PyPI | All versions | 2.7.0 |
| `airflow` | Bitnami | All versions | 2.7.0 |
| `apache-airflow-providers-imap` | PyPI | All versions | 3.3.0 |
| `apache-airflow-providers-imap` | PyPI | All versions | 3.3.0 |
| `apache-airflow-providers-imap` | PyPI | All versions | 3.3.0 |
| `apache-airflow-providers-smtp` | PyPI | All versions | 1.3.0 |
| `apache-airflow-providers-smtp` | PyPI | All versions | 1.3.0 |
| `apache-airflow-providers-smtp` | PyPI | All versions | 1.3.0 |

Products: Apache Airflow, Apache Apache-Airflow-Providers-Imap, Apache Apache-Airflow-Providers-Smtp.

## How do I fix CVE-2023-39441?

Upgrade apache-airflow to 2.7.0 or later.

## Is CVE-2023-39441 being exploited?

There is no known exploitation of CVE-2023-39441 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow

- [CVE-2020-13927](https://insights.sbomify.com/CVE-2020-13927/): Apache Airflow's Experimental API Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-11978](https://insights.sbomify.com/CVE-2020-11978/): Apache Airflow Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-33264](https://insights.sbomify.com/CVE-2026-33264/): Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize() (critical 9.8)
- [CVE-2023-25754](https://insights.sbomify.com/CVE-2023-25754/): Apache Airflow: Privilege escalation using airflow logs (critical 9.8)
- [CVE-2023-22884](https://insights.sbomify.com/CVE-2023-22884/): Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-39441 and fix it if it is affected.

What it is: CVE-2023-39441 is a medium-severity vulnerability in Apache Airflow, published on 23 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-39441 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow (PyPI): affected all versions; fixed in 2.7.0
- apache-airflow (PyPI): affected all versions; fixed in 2.7.0
- apache-airflow (PyPI): affected all versions; fixed in 2.7.0
- airflow (Bitnami): affected all versions; fixed in 2.7.0
- apache-airflow-providers-imap (PyPI): affected all versions; fixed in 3.3.0
- apache-airflow-providers-imap (PyPI): affected all versions; fixed in 3.3.0
- apache-airflow-providers-imap (PyPI): affected all versions; fixed in 3.3.0
- apache-airflow-providers-smtp (PyPI): affected all versions; fixed in 1.3.0
- apache-airflow-providers-smtp (PyPI): affected all versions; fixed in 1.3.0
- apache-airflow-providers-smtp (PyPI): affected all versions; fixed in 1.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-39441/ (Markdown: https://insights.sbomify.com/CVE-2023-39441/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-39441
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-39441
- OSV: https://osv.dev/vulnerability/CVE-2023-39441

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-39441/
Summaries are generated and may contain mistakes; the official description above is the record.
