CVE-2023-39456 Apache Traffic Server: Malformed http/2 frames can cause an abort

High 7.5 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2023-39456?

CVE-2023-39456 is a high-severity vulnerability in Apache Traffic Server, published on 17 Oct 2023.

Official description

Improper Input Validation vulnerability in Apache Traffic Server with malformed HTTP/2 frames.This issue affects Apache Traffic Server: from 9.0.0 through 9.2.2.

Users are recommended to upgrade to version 9.2.3, which fixes the issue.

Weakness: CWE-20

Which versions are affected by CVE-2023-39456?

It affects 2 products.

Products include Apache Traffic Server, Fedoraproject Fedora.

How do I fix CVE-2023-39456?

Upgrade to a fixed version.

Is CVE-2023-39456 being exploited?

There is no known exploitation of CVE-2023-39456 in the wild and no public exploit code.

All Apache Traffic Server vulnerabilities

Sources

Also known as DEBIAN-CVE-2023-39456, GHSA-fr7h-j3xj-fvvv, OESA-2025-1659, UBUNTU-CVE-2023-39456.

Is CVE-2023-39456 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free