# CVE-2023-39456: Apache Traffic Server: Malformed http/2 frames can cause an abort


- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 17 Oct 2023
- **Updated:** 12 Jun 2025
- **Also known as:** DEBIAN-CVE-2023-39456, GHSA-fr7h-j3xj-fvvv, OESA-2025-1659, UBUNTU-CVE-2023-39456

## What is CVE-2023-39456?

CVE-2023-39456 is a high-severity vulnerability in Apache Traffic Server, published on 17 Oct 2023. 

### Official description

Improper Input Validation vulnerability in Apache Traffic Server with malformed HTTP/2 frames.This issue affects Apache Traffic Server: from 9.0.0 through 9.2.2.

Users are recommended to upgrade to version 9.2.3, which fixes the issue.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2023-39456?

It affects 2 products.


Products: Apache Traffic Server, Fedoraproject Fedora.

## How do I fix CVE-2023-39456?

Upgrade to a fixed version.

## Is CVE-2023-39456 being exploited?

There is no known exploitation of CVE-2023-39456 in the wild and no public exploit code.

## Other vulnerabilities in Apache Traffic Server

- [CVE-2014-3525](https://insights.sbomify.com/CVE-2014-3525/): Other in n/a (critical 10.0)
- [CVE-2021-43082](https://insights.sbomify.com/CVE-2021-43082/): heap-buffer-overflow with stats-over-http plugin (critical 9.8)
- [CVE-2021-35474](https://insights.sbomify.com/CVE-2021-35474/): Dynamic stack buffer overflow in cachekey plugin (critical 9.8)
- [CVE-2019-17559](https://insights.sbomify.com/CVE-2019-17559/): Other in Apache Traffic Server (critical 9.8)
- [CVE-2019-17565](https://insights.sbomify.com/CVE-2019-17565/): Other in Apache Traffic Server (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-39456 and fix it if it is affected.

What it is: CVE-2023-39456 is a high-severity vulnerability in Apache Traffic Server, published on 17 Oct 2023. 
Exploitation: There is no known exploitation of CVE-2023-39456 in the wild and no public exploit code.

Affected product: Apache Traffic Server. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-39456/ (Markdown: https://insights.sbomify.com/CVE-2023-39456/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-39456
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-39456
- OSV: https://osv.dev/vulnerability/CVE-2023-39456

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-39456/
Summaries are generated and may contain mistakes; the official description above is the record.
