# CVE-2023-39525: PrestaShop vulnerable to path traversal

> Attackers can compromise files in the PrestaShop back office by exploiting a path traversal vulnerability in the import file deletion query.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Aug 2023
- **Updated:** 3 Oct 2024
- **Also known as:** GHSA-m9r4-3fg7-pqm2

## What is CVE-2023-39525?

CVE-2023-39525 is a medium-severity path traversal vulnerability in Prestashop Prestashop, published on 7 Aug 2023. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

PrestaShop is an open source e-commerce web application. Prior to version 8.1.1, in the back office, files can be compromised using path traversal by replaying the import file deletion query with a specified file path that uses the traversal path. Version 8.1.1 contains a patch for this issue. There are no known workarounds.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2023-39525?

2 open source packages ship an affected version, including prestashop/prestashop. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `prestashop/prestashop` | Packagist | All versions | 8.1.1 |
| `prestashop/prestashop` | Packagist | All versions | 8.1.1 |

Products: Prestashop Prestashop.

## How do I fix CVE-2023-39525?

Upgrade prestashop/prestashop to 8.1.1 or later.

## Is CVE-2023-39525 being exploited?

There is no known exploitation of CVE-2023-39525 in the wild and no public exploit code.

## Other vulnerabilities in Prestashop Prestashop

- [CVE-2023-30839](https://insights.sbomify.com/CVE-2023-30839/): PrestaShop vulnerable to SQL filter bypass leading to arbitrary write requests using "SQL Manager" (critical 10.0)
- [CVE-2008-5791](https://insights.sbomify.com/CVE-2008-5791/): Other in n/a (critical 10.0)
- [CVE-2024-41651](https://insights.sbomify.com/CVE-2024-41651/): Server-side request forgery in n/a (critical 9.8)
- [CVE-2022-31181](https://insights.sbomify.com/CVE-2022-31181/): Remote code execution in prestashop (critical 9.8)
- [CVE-2021-3110](https://insights.sbomify.com/CVE-2021-3110/): SQL injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-39525 and fix it if it is affected.

What it is: CVE-2023-39525 is a medium-severity path traversal vulnerability in Prestashop Prestashop, published on 7 Aug 2023. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-39525 in the wild and no public exploit code.

Affected packages and fixed versions:
- prestashop/prestashop (Packagist): affected all versions; fixed in 8.1.1
- prestashop/prestashop (Packagist): affected all versions; fixed in 8.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-39525/ (Markdown: https://insights.sbomify.com/CVE-2023-39525/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-39525
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-39525
- OSV: https://osv.dev/vulnerability/CVE-2023-39525

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-39525/
Summaries are generated and may contain mistakes; the official description above is the record.
