CVE-2023-39526 PrestaShopSQL manager vulnerability (potential RCE)
Attackers can achieve remote code execution via SQL injection and arbitrary file write in the PrestaShop back office.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-39526?
CVE-2023-39526 is a critical SQL injection vulnerability in Prestashop Prestashop, published on 7 Aug 2023. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
PrestaShop is an open source e-commerce web application. Versions prior to 1.7.8.10, 8.0.5, and 8.1.1 are vulnerable to remote code execution through SQL injection and arbitrary file write in the back office. Versions 1.7.8.10, 8.0.5, and 8.1.1 contain a patch. There are no known workarounds.
Weakness: CWE-89
Which versions are affected by CVE-2023-39526?
6 open source packages ship an affected version, including prestashop/prestashop. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
prestashop/prestashop Packagist | All versions | 1.7.8.10 |
prestashop/prestashop Packagist | All versions | 1.7.8.10 |
prestashop/prestashop Packagist | From 8.0.0 | 8.0.5 |
prestashop/prestashop Packagist | From 8.0.0 | 8.0.5 |
prestashop/prestashop Packagist | From 8.1.0 | 8.1.1 |
prestashop/prestashop Packagist | From 8.1.0 | 8.1.1 |
Products include Prestashop Prestashop.
How do I fix CVE-2023-39526?
Upgrade prestashop/prestashop to a fixed version for your release line: 1.7.8.10, 8.0.5 or 8.1.1.
Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.
Is CVE-2023-39526 being exploited?
There is no known exploitation of CVE-2023-39526 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Prestashop Prestashop
Sources
Also known as GHSA-gf46-prm4-56pc.