# CVE-2023-39526: PrestaShopSQL manager vulnerability (potential RCE)

> Attackers can achieve remote code execution via SQL injection and arbitrary file write in the PrestaShop back office.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Aug 2023
- **Updated:** 10 Oct 2024
- **Also known as:** GHSA-gf46-prm4-56pc

## What is CVE-2023-39526?

CVE-2023-39526 is a critical SQL injection vulnerability in Prestashop Prestashop, published on 7 Aug 2023. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

PrestaShop is an open source e-commerce web application. Versions prior to 1.7.8.10, 8.0.5, and 8.1.1 are vulnerable to remote code execution through SQL injection and arbitrary file write in the back office. Versions 1.7.8.10, 8.0.5, and 8.1.1 contain a patch. There are no known workarounds.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2023-39526?

6 open source packages ship an affected version, including prestashop/prestashop. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `prestashop/prestashop` | Packagist | All versions | 1.7.8.10 |
| `prestashop/prestashop` | Packagist | All versions | 1.7.8.10 |
| `prestashop/prestashop` | Packagist | From 8.0.0 | 8.0.5 |
| `prestashop/prestashop` | Packagist | From 8.0.0 | 8.0.5 |
| `prestashop/prestashop` | Packagist | From 8.1.0 | 8.1.1 |
| `prestashop/prestashop` | Packagist | From 8.1.0 | 8.1.1 |

Products: Prestashop Prestashop.

## How do I fix CVE-2023-39526?

Upgrade prestashop/prestashop to a fixed version for your release line: 1.7.8.10, 8.0.5 or 8.1.1.

## Is CVE-2023-39526 being exploited?

There is no known exploitation of CVE-2023-39526 in the wild and no public exploit code.

Public exploit code:

- Prestashop fix vulnerability CVE-2023-39526 & CVE-2023-39527 (github_poc): https://github.com/dnkhack/fixcve2023_39526_2023_39527

## Other vulnerabilities in Prestashop Prestashop

- [CVE-2023-30839](https://insights.sbomify.com/CVE-2023-30839/): PrestaShop vulnerable to SQL filter bypass leading to arbitrary write requests using "SQL Manager" (critical 10.0)
- [CVE-2008-5791](https://insights.sbomify.com/CVE-2008-5791/): Other in n/a (critical 10.0)
- [CVE-2024-41651](https://insights.sbomify.com/CVE-2024-41651/): Server-side request forgery in n/a (critical 9.8)
- [CVE-2022-31181](https://insights.sbomify.com/CVE-2022-31181/): Remote code execution in prestashop (critical 9.8)
- [CVE-2021-3110](https://insights.sbomify.com/CVE-2021-3110/): SQL injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-39526 and fix it if it is affected.

What it is: CVE-2023-39526 is a critical SQL injection vulnerability in Prestashop Prestashop, published on 7 Aug 2023. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-39526 in the wild and no public exploit code.

Affected packages and fixed versions:
- prestashop/prestashop (Packagist): affected all versions; fixed in 1.7.8.10
- prestashop/prestashop (Packagist): affected all versions; fixed in 1.7.8.10
- prestashop/prestashop (Packagist): affected from 8.0.0; fixed in 8.0.5
- prestashop/prestashop (Packagist): affected from 8.0.0; fixed in 8.0.5
- prestashop/prestashop (Packagist): affected from 8.1.0; fixed in 8.1.1
- prestashop/prestashop (Packagist): affected from 8.1.0; fixed in 8.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-39526/ (Markdown: https://insights.sbomify.com/CVE-2023-39526/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-39526
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-39526
- OSV: https://osv.dev/vulnerability/CVE-2023-39526

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-39526/
Summaries are generated and may contain mistakes; the official description above is the record.
