CVE-2023-39527 PrestaShop XSS vulnerability through Validate::isCleanHTML method
Attackers can execute arbitrary scripts in victim browsers via the isCleanHTML method, potentially leading to session hijacking or data theft.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2023-39527?
CVE-2023-39527 is a high-severity cross-site scripting vulnerability in Prestashop Prestashop, published on 7 Aug 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Official description
PrestaShop is an open source e-commerce web application. Versions prior to 1.7.8.10, 8.0.5, and 8.1.1 are vulnerable to cross-site scripting through the `isCleanHTML` method. Versions 1.7.8.10, 8.0.5, and 8.1.1 contain a patch. There are no known workarounds.
Which versions are affected by CVE-2023-39527?
6 open source packages ship an affected version, including prestashop/prestashop. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
prestashop/prestashop Packagist | All versions | 1.7.8.10 |
prestashop/prestashop Packagist | All versions | 1.7.8.10 |
prestashop/prestashop Packagist | From 8.0.0 | 8.0.5 |
prestashop/prestashop Packagist | From 8.0.0 | 8.0.5 |
prestashop/prestashop Packagist | From 8.1.0 | 8.1.1 |
prestashop/prestashop Packagist | From 8.1.0 | 8.1.1 |
Products include Prestashop Prestashop.
How do I fix CVE-2023-39527?
Upgrade prestashop/prestashop to a fixed version for your release line: 1.7.8.10, 8.0.5 or 8.1.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2023-39527 being exploited?
There is no known exploitation of CVE-2023-39527 in the wild and no public exploit code.
Other vulnerabilities in Prestashop Prestashop
Sources
Also known as GHSA-xw2r-f8xv-c8xp.